Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Messages remain in the local delivery queue but do not generate NDRs


View products that this article applies to.

Symptoms

When you review the Local Delivery queue on your Exchange 2000 Server computer, some messages may not be sent. However non-delivery reports (NDRs) may not be generated. The Event Viewer Application log may contain the following event:

Event Type: Warning
Event Source: MSExchangeTransport
Event Category: (5)
Event ID: 327
User: N/A
Description: The following call : EcSetFileHandleProp to the store failed. Error code : -2147467259. MDB : f9c84d92-8e68-459b-a658-f019bfbec2ae. FID : . MID : . File : J:\EXCHSRVR\Mailroot\vsi 1\Queue\NTFS_2d3f9f1601c2916200060320.EM

↑ Back to the top


Cause

This problem may occur if the message header is malformed. If the message header is malformed, the message stays in the Local Delivery queue, and an NDR is not sent.

↑ Back to the top


Resolution

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824282� September 2003 Exchange 2000 Server post-Service Pack 3 rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. Component: The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   -----------------------------------------------------------
   23-Jan-2003  00:23  6.0.6405.0      4,591,616  Store.exe
   23-Jan-2003  00:37  6.0.6405.0      3,915,776  Cdoex.dll
   23-Jan-2003  00:37  6.0.6405.0      3,571,712  Excdo.dll
   23-Jan-2003  00:24  6.0.6405.0        258,048  Exmime.dll
   23-Jan-2003  00:28  6.0.6405.0      1,691,648  Exoledb.dll
   22-Jan-2003  23:55  6.0.6405.0      2,265,088  Mdbmsg.dll
   22-Jan-2003  23:24  6.0.6405.0         32,768  Mdbrole.dll
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378� How to obtain the latest Exchange 2000 Server service pack

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB813781, kbqfe, kbprb, kberrmsg, kbenv, kbfix, kbexchange2000presp4fix, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 813781
Revision : 11
Created on : 2/21/2007
Published on : 2/21/2007
Exists online : False
Views : 216