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The TCP/IP stack does not permit a connection to remain in a FINWAIT-2 status for longer than 300 seconds


View products that this article applies to.

Symptoms

If you use a program that makes a call to the shutdown(s, SD_SEND) function, the TCP connection is forced to close within five minutes (300 seconds). Because of this forced closure of the TCP connection, any data that cannot be delivered within the five-minute time frame is not received by the client.

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Cause

This issue occurs because the TCP/IP stack forces the TCP connection to close five minutes after the shutdown(s, SD_SEND) function is called. The TCP/IP stack does not permit a connection to remain in a FINWAIT-2 status for longer than five minutes.

This forced closure of the connection may cause a problem if the client and the server are connected through a slow network connection. After the client calls the shutdown(s, SD_SEND) function, and the server receives the TCP-FIN request, the server has the option to send the data in the TCP send buffer before the server closes the connection. However, because of the slow link speed, the TCP send buffer may take longer than five minutes to transfer the data to the client. After five minutes, the TCP/IP stack on the client has already closed the connection. In this scenario, the Winsock API select() function on the client returns a WSAECONNRESET (connection was reset by remote network) response, and therefore, some of the data may be lost.

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Resolution

Microsoft Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name     Platform
   ----------------------------------------------------------------------
   20-Aug-2003  22:19  5.2.3790.78       334,336  Tcpip.sys     x86

   20-Aug-2003  22:16  5.2.3790.78       969,728  Tcpip.sys     IA-64

Microsoft Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name     Platform
   ----------------------------------------------------------------------
   28-Aug-2003  17:56  5.1.2600.1265     333,440  Tcpip.sys     x86
   27-Aug-2003  01:45  5.1.2600.1265   1,093,248  Tcpip.sys     IA-64

Microsoft Windows 2000

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   18-Jul-2003  20:00  5.0.2195.6787     118,992  Afd.sys
   18-Jul-2003  23:20  5.0.2195.6602     108,816  Msafd.dll        
   18-Jul-2003  20:33  5.0.2195.6787     314,928  Tcpip.sys
   15-Jan-2003  20:56  5.0.2195.6655      16,240  Tdi.sys
   18-Jul-2003  23:20  5.0.2195.6601      17,680  Wshtcpip.dll       

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP

This problem was first corrected in Microsoft Windows XP Service Pack 2.

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More information

After you apply this hotfix, you must create the following REG_DWORD registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TCPFinWait2Delay
This registry value controls how many seconds that a TCP connection waits before it is forced to close after the shutdown(s, SD_SEND) function is called. The default value is 240 seconds. The range for this value is from 30 to 294,967,295. This registry value must be created manually. Otherwise, the default value is used.

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbqfe, kbwinxpsp2fix, kbwinxppresp2fix, kbwinserv2003presp1fix, kbbug, kbfix, kbqfe, kbwin2000presp5fix, KB813056

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Article Info
Article ID : 813056
Revision : 10
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 257