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FIX: Query on Virtual Catalog Returns No Results


View products that this article applies to.

Symptoms

When you query on a word in a virtual catalog, the query returns no results. When you query on the same word in the base catalog, the query returns hits.

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Cause

There are many factors that might cause your query to fail. For your query to work as expected, the following must be true:
  • The virtual catalog was rebuilt after you added inclusion rules.
  • The set of supported languages for the virtual catalog is a subset of the set of supported languages for the base catalog.
  • The default language for the virtual catalog and for the base catalog must be the same.
  • In the Commerce Server Business Desk (BizDesk) Catalog Editor, Up-to-date must appear in the status column.
If your virtual catalog query still does not return results, apply the hotfix, and then follow the steps in the "More Information" section.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size     File name
   ------------------------------------------------------
   02-Jan-2003  18:28  602,697  Catalogcreate.sql
   20-Dec-2002  02:43    7,081  Applypricerulestodesc.sql
NOTE: Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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More information

To correct this problem, follow these steps:
  1. Make a backup copy of your catalog.
  2. Install Microsoft Commerce Server 2002 SP1.
  3. Start Microsoft SQL Query Analyzer.
  4. On the File menu, click Open, and then locate the SP1 folder in your Commerce Server installation.
  5. Click the CatalogSP1Migration.sql file.
  6. In the right pane, press CTRL+A to select all.
  7. Press CTRL+E to run the script.
  8. On the File menu, click Open, and then locate the hotfix folder.
  9. Click the ApplyPriceRulesToDesc.sql file.
  10. In the right pane, press CTRL+A to select all.
  11. Press CTRL+E to run the script.
  12. Click Start, and then click Run.
  13. In the Open text box, type iisreset, and then click OK to reset your site.

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Keywords: KB811970, kbbug, kbfix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 811970
Revision : 6
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 380