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BizDesk Campaign Manager Fails with "Call to Server.CreateObject Failed While Checking Permissions" Error Message


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Symptoms

After you modify the access security settings in Component Services (Dcomcnfg.exe), you may receive the following error message when you try to use the Campaign module in your BizDesk:
0x80070005 006~ASP 0178~Server.CreateObject Access Error~The call to Server.CreateObject failed while checking permissions. Access is denied to this object.
This problem can occur with any of the following services:
  • Microsoft Commerce Server DirectMailer Service
  • Microsoft Commerce Server ListManager Service
  • Microsoft Commerce Server Predictor Service

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Cause

For stronger security, these services are locked down for Distributed Component Object Model (DCOM) access.

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Resolution

Use Dcomcnfg.exe to explicitly grant permission. Include the DirectMailer Service account in the group that has access to the ListManager Service. The Campaign Manager BizDesk module requires that the account has access to both services.

Additionally, plan and document all required changes to Dcomcnfg security before you modify any of the settings.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
328522 HOW TO: Set Access Security on Commerce Server Services by Using Dcomcnfg.exe

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Keywords: KB811306, kbprb

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Article Info
Article ID : 811306
Revision : 3
Created on : 3/12/2003
Published on : 3/12/2003
Exists online : False
Views : 382