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Jetstress will not load performance counters after applying a service pack or hotfix


Author: Andy David MVP

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Summary

Jetstress will not load performance counters after applying a service pack or hotfix to a test Exchange server.

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Symptoms

After applying a hotfix or service pack to a test Exchange server, the Jetstress program will no longer start and fails when loading performance counters.
Errors include "Process failed to load database performance counters. Please make sure that all database performance counters are working properly with System Monitor."
Clicking the "Fix Errors" button does not solve the issue.

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Cause

Jetstress relies on�four files to function correctly:�ESE.DLL,�ESEPERF.DLL,�ESEPERF.INI and�ESEPERF.HXX. If the versions of these files in the Jetstress install directory do not match the versions installed in the Exchange bin directory, you will see the errors described above.


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Resolution

Per�the Jetstress documentation: "In a command shell window, enter the command �unlodctr ESE� and press Enter. This will unregister the ESE Database performance counters".
Doing�so should fix this issue, however, Microsoft recommends that you test using the same version of the ese.dll as will be used in production. To meet this requirement, copy the updated versions of the�four required dll files from the Exchange bin directory into the Jetstress install directory before restarting Jetstress again so that it can reload the performance counters using the correct�ESE library files.

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More information

Do not use Jetstress in a production environment.
Installing Exchange is not a requirement to use Jetstress. See the Jetstress documentation for more information.
http://www.microsoft.com/downloads/details.aspx?FamilyId=94B9810B-670E-433A-B5EF-B47054595E9C&displaylang=en


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Keywords: KB555554, kbhowto, kbpubtypecca, kbpubmvp

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Article Info
Article ID : 555554
Revision : 1
Created on : 1/13/2006
Published on : 1/13/2006
Exists online : False
Views : 284