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Screen sharing fails on Skype for Business 2016 32-bit client


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Symptoms

In Microsoft Skype for Business 2016, consider the following scenario:
  • You install the Skype for Business 2016 32-bit client.
  • You sign in and leave the client running for several days.
  • You may have multiple monitors, or monitors that use a very high resolution.
  • You try to start a screen sharing session.
In this situation, the screen sharing fails. In addition, the following error message is shown in the Skype for Business UCCAPI log:
Appsharing session disconnected due to failures in RDP stack

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Cause

When sharing screen, the Skype for Business client must allocate a contiguous buffer based on the resolution of all your monitors. 32-bit applications have certain memory limitations due to their architecture. After the Skype for Business client is left running for several days, the available memory space can fragment, leaving less contiguous memory available. If there is not a contiguous block of available memory for the screen sharing, it will fail.

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Resolution

To fix this issue, install the September 1, 2020, update (KB4484501) for Microsoft Skype for Business 2016.

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More information

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Keywords: CI122508, kbHotfixAuto, screen sharing fails on 32-bit client, kbfix, kb

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Article Info
Article ID : 4576657
Revision : 6
Created on : 9/1/2020
Published on : 9/1/2020
Exists online : False
Views : 179