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CDS User Role cannot access Power Automate flows, business process flows or on-demand workflows


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Symptoms

Users that are assigned only the 'CDS User' role are unable to access previously available Power Automate flows, business process flows or on-demand workflows.

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Cause

The 'CDS User' role is being updated to match the needs of a default user, to ensure that they can use flows shared with them or created by them.

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Resolution

Any one of these options:

  1. Explicitly share the workflows with users that need access to them.
  2. Create a new role with the desired access-level privileges on Process entity and assign to users that need it ('User','Team','Business Unit','Parent-Child Business Unit','Organization').
  3. Modify the existing 'CDS User' role to the desired access-level privilege.

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Keywords: cds, common data service, cds user role, user roles, privileges, workflows, bpf, business process flows, flows, power automate, on demand workflows, role privileges

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Article Info
Article ID : 4562298
Revision : 5
Created on : 5/11/2020
Published on : 5/12/2020
Exists online : False
Views : 204