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Ringback tone occurs for on hold call if SIP URI and Line URI are similar in Skype for Business 2016 (Click-to-Run)


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Symptoms

Consider this scenario in Microsoft Skype for Business 2016 (Click-to-Run):
  • User A has a SIP URI that starts with a plus sign followed by a few digits, formatted like a TEL URI. For example, sip:+15555555555@contoso.com.
  • User A also has a Line URI that matches the number in the SIP URI. For example, tel:+15555555555.
  • User B tries to call the Line URI of the first user, and upon connecting places the call on hold.
In this situation, user B hears a ringback tone while the call is on hold. 

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Cause

This issue occurs due to the similarities between the SIP URI and Line URI. The client fails to raise certain events, which causes the call to stay in a ringing state.

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Resolution

To fix this issue, make sure that the client version is higher than 16.0.13029.20200.

To enable this fix, create a policy by using one of the following options.
  1. Create the following registry key on the client computers:

    Root: HKEY_LOCAL_MACHINE or HKEY_CURRENT_USER
    Key: Software\Policies\Microsoft\Office\16.0\Lync
    Value Type: DWORD
    Value Name: EnablePAISIPContainedComparison
    Value Data: 0x00000001
  2. Create the following client policy entry by using the Skype for Business PowerShell:

    $x = New-CsClientPolicyEntry -Name "EnablePAISIPContainedComparison" -Value "true"
    Set-CsClientPolicy -Identity "<ClientPolicyName>" -PolicyEntry @{Add=$x}

    Note
    When configuring via the client policy entry, a user must sign in to Skype for Business after the policy has been applied to receive the new policy information, and then sign out and sign in again for it to take effect.

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Keywords: CI119751, kbHotfixAuto, kbqfe, kbfix, kb, ringback tone occurs for on hold call

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Article Info
Article ID : 4559452
Revision : 12
Created on : 7/30/2020
Published on : 7/30/2020
Exists online : False
Views : 157