Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"You don’t have required role or privilege to complete this action" error occurs in Dynamics 365 App for Outlook


View products that this article applies to.

Symptom

When attempting to use the Dynamics 365 App for Outlook, you see the following message: 

You don’t have required role or privilege to complete this action. Please contact your administrator to get necessary access.”

↑ Back to the top


Cause

This message can appear when a user without the System Administrator role tries to open Dynamics 365 App for Outlook and their mailbox is configured with a Dynamics 365 Sandbox environment with Admin mode turned enabled. When Admin Mode is enabled, only users with the System Administrator role can access the environment. 

↑ Back to the top


Article Info
Article ID : 4555675
Revision : 2
Created on : 3/31/2020
Published on : 3/31/2020
Exists online : False
Views : 245