Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

MCDB status is "Offline" and SSDs are not formatted in Exchange Server 2019


View products that this article applies to.

Symptoms

Assume that you deploy Microsoft Exchange Server 2019 in Windows Server 2019. You use the Manage-MetaCacheDatabase.ps1 script to enable MetaCacheDatabase (MCDB).
For example:
Manage-MCDB -DagName TestDag1 -ServerAllowMCDB $false -ServerName "exhs-5046" -ForceFailover $true​

Then, you use the Get-MailboxDatabaseCopyStatus cmdlet to view the health and status information for the database copies.​
For example:​
Get-MailboxDatabaseCopyStatus | Fl name, *meta*​

Name : DB01\Server01​
MetaCacheDatabaseStatus : Offline​
MetaCacheDatabaseStatusMessage : Partition not attached in active Store worker process.​
MetaCacheDatabaseFilePath : C:\ExchangeMetaCacheDbs\DB01\DB01.mcdb\DB01-mcdb.edb​
MetaCacheDatabaseLastReset :​
This example returns the status for the copy of database DB01 on Mailbox server Server01.​

In the results, you find that the solid state drive (SSD) is not formatted as expected, and the MCDB status is "Offline". Additionally, not all designated SSDs are formatted, and mount points are not created as expected.

↑ Back to the top


Cause

This issue occurs because of a new behavior in Windows Server 2019 that causes Get-Disk to return all uninitialized discs within the database availability group (DAG) or cluster, and the script incorrectly tries to format an SSD on another DAG member.

↑ Back to the top


Resolution

To fix this issue, install the Cumulative Update 5 for Exchange Server 2019 or a later cumulative update for Exchange Server 2019.

↑ Back to the top


References

Learn about the terminology that Microsoft uses to describe software updates.

↑ Back to the top


Keywords: CI114696, kbHotfixAuto, MetaCacheDatabase not provisioning disks cprrectly, kbqfe, kbfix, kb

↑ Back to the top

Article Info
Article ID : 4547719
Revision : 9
Created on : 3/17/2020
Published on : 3/17/2020
Exists online : False
Views : 381