Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

DWM.exe process stops responding when you repeatedly close and open the lid in Windows 10, version 1809


View products that this article applies to.

Symptoms

Consider the following scenarios.

Scenario 1

  • You plug a High-Definition Multimedia Interface (HDMI) monitor into a laptop computer that is running Windows 10, version 1809.
  • The monitor is configured to operate at 4K resolution.
  • You repeatedly play a 4K H264 video in Movies & TV on the computer.
  • In Control Panel, you open the Advanced settings screen of the Power Options item, and then you set Lid close action as Do nothing.
  • While the 4K video is playing back, you repeatedly close and open the computer lid.

Scenario 2

  • You connect two 4K monitors to a Thunderbolt 3 docking station.
  • You connect a laptop that has a 4K solution monitor to the docking station, and then you configure a triple 4K display configuration in either "clone" or "extend" mode.
  • You repeatedly undock and redock the laptop.

In these scenarios, the Desktop Windows Manager (DWM.exe) process stops responding.

↑ Back to the top


Cause

This problem occurs because of an issue in the Microsoft DirectX Video Memory Management (Dxgmms2.sys) component. This is not a hardware issue.

↑ Back to the top


Resolution

To fix this problem, upgrade the computer to the latest version of Windows 10.

↑ Back to the top


Keywords: An application or process hangs or crashes, kbContentAuto, kbSupportTopic

↑ Back to the top

Article Info
Article ID : 4502866
Revision : 7
Created on : 5/14/2019
Published on : 5/14/2019
Exists online : False
Views : 381