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Solution install fails due to dependencies that do not exist in a CDS environment


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Symptom

When you attempt to import a solution in Dynamics 365, the import fails due to missing dependencies. If you are installing the solution from the administration center, you may just see a message indicating installation failed. If you are importing a solution from the Dynamics 365 web application, you may see additional details such as what dependencies are missing.

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Cause

This can occur if the solution requires components that do not exist in a Common Data Service (CDS) environment. A CDS only environment does not have all the entities included and only includes some standard entities. If the solution you are attempting to install depends on an entity that does not exist in your environment (ex. an entity that only exists in the sales app), the solution would fail to install successfully. 

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Resolution

Only attempt to install the solution in an environment that includes the required components. There are a number of solutions that can be found in the Administration Center and AppSource that can only be installed if you have certain licenses such as a license that includes the Sales app.

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Article Info
Article ID : 4499731
Revision : 2
Created on : 4/12/2019
Published on : 4/12/2019
Exists online : False
Views : 196