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Unable to import Dynamics 365 solution or install an app due to web resource size


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Symptom

When attempting to import a Dynamcis 365 solution or install an app, the import/install fails. If you are importing a solution from within the Dynamics 365 web application, you may see a reference to error code 8004f114. If you are installing an app from the administration center, you may only see a message indicating the installation failed.

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Cause

If you have modified the attachment size limit within System Settings to be smaller than the default value of 5MB, this can cause solution import to fail if it contains a web resource that is larger than the limit you have configured.

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Resolution

  1. As a user with the System Administrator security role, access the Dynamics 365 web application and navigate to Settings and then click Administration
  2. Click System Settings and then click the Email tab. 
  3. Locate the section titled Set file size limit for attachments to find the option Maximum file size.
  4. If the current setting is lower than the default limit of 5,120 kb, change the value back to 5,120 and then click OK
  5. Try to import the solution again.

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Keywords: 8004f114, -2147159788, 0x8004f114, solution

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Article Info
Article ID : 4499713
Revision : 2
Created on : 4/12/2019
Published on : 4/12/2019
Exists online : False
Views : 244