Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Accessing Partner Sales Connect for the First Time


View products that this article applies to.

Summary

If you are experiencing difficulties while logging in to Partner Sales Connect, skip down to Section B.

Unlike some other Microsoft Partner-Portals you might frequent, Partner Sales Connect must federate with an Azure Active Directory (AAD) tenant owned by your firm in order to verify your identity.

If your company uses Office 365, it’s likely you’ll only need the first portion of this guide. Otherwise, or if your company has strict security requirements, you may need to associate yourself to an AAD tenant or you may need to contact your IT Admin to grant PSC the permissions which it needs to read you and your company’s profiles.

If you’re not sure whether your company uses Office 365 or has AAD Single-Sign On, start with Section A.

↑ Back to the top


Section A: First Time Logging In

First, we’ll walk through what your first sign-in will look like if your corporate email address is already aligned with an AAD tenant (with default user-permission settings).

Please do not use a LiveID account/email address like <some-username>@outlook.com nor <some-username>@hotmail.com nor <some-username>@live.com.

That will lead you to one of the failure modes covered in Section B.

  1. First, open an InPrivate/Incognito browser/New Private Window.
  2. Navigate to https://partnersales.microsoft.com
  3. You’ll be redirected to a Microsoft Login page which will ask you to enter an “Email, Phone, or Skype.”
    Make sure your first attempt at signing in is done with the email address to which your PSC invitation was sent.

    PSC1
  4. Most often, you will next be asked if you want to use a “Work or school account (Created by your IT department)” or a “Personal account (created by you.)” Make sure you select “Work or school account” or you’ll eventually receive this screen.

    PSC2
  5. You’ll be prompted for your password. Enter the one you normally use to login to your email inbox. Since PSC will be federating with your corporate tenant, you’ll use your normal corporate password to login. This password will be used by your company’s AAD tenant to verify that it is actually you who is requesting, via the AAD tenant behind PSC, to access the app.

    PSC3
  6. After pressing the “Sign in” button, and assuming you’re the first person from your organization to login to PSC in the last year, you should see the following. If you don’t, check Sections B3 & B4, or reach out to cosell@microsoft.com if you require further assistance. Clicking the check-box next to “Consent on behalf of your organization” is not required for you to press “Accept.” However, the next person logging in from your organization will also receive this option until someone consents.
    Also, note that your organization’s usage of PSC is not supported until you or someone else in your firm consents.
    PSC4
  7. Assuming you consented on behalf of your organization, you’ll be redirected to the terms page and asked for your default language. Upon selection, the actual terms page will be displayed.
    Note that usage of PSC is governed by the Microsoft Partner Network Agreement. You can find a link to it on this screen. You must press “Accept” to proceed from here.
    PSC5
  8. You should now see the following screen. Welcome to Partner Sales Connect! Reach out to cosell@microsoft.com to set up a walkthrough of the portal. In future login attempts, you will only need to perform steps 2-4.
    PSC

↑ Back to the top


Section B: Troubleshooting

 

B1

Common-Error Index

Entering an @outlook.com, @hotmail.com, or @live.com Email Address

Common Errors

Your live.com#Customer@Companyname.com account is not authorized to use Microsoft Partner Sales Connect at this time.

error

PSC6

Cause

You’ve attempted to login with a LiveID or you’ve selected “Personal account” when given the option between “Work or school account” vs “Personal account.”

Resolution

You must use a company or school email address to login. If you’ve attempted that & are experiencing another error, please review the other errors in this guide or reach out to cosell@microsoft.com if none of the displayed screenshots reflect your issue.

B2

Common-Error Index

Selection of “Personal account” When Prompted

Common Errors

User account xxxxxx@xxxx.com from identity provider 'live.com' does not exist in tenant 'Microsoft' and cannot access the application.

PSC7

Cause

You’ve attempted to login with a LiveID or you’ve selected “Personal account” when given the option between “Work or school account” vs. “Personal account.”

Resolution

Same as B1. You must use a company or school email address to login. If you’ve attempted that & are experiencing another error, find it in lower in this guide or reach out to cosell@microsoft.com if none of the displayed screenshots reflect your issue.

B3.

Common-Error Index

Password Not Correct OR No Tenant Found Behind Your Email Address

Common Errors

PSC8

Cause

This does not necessarily mean your password is incorrect. It is possible that your email address isn’t managed by exchange and/or that your organization doesn’t use AAD to manage employee user-accounts.

Resolution

a. If you’ve ever seen a <username>@<mycompany>.onmicrosoft.com account used within your organization, you’ll likely want to get yourself associated to an existing tenant. Please have your companies IT Admin generate a new username on an AAD tenant here.
Note: Your IT Admin on the tenant must complete these steps.

b. If you’re your company does not use <username>@<mycompany>.onmicrosoft.com accounts, you can also create a new tenant. See “Section C: Creating an AAD Tenant for My Company.”

B4

Common-Error Index

Login Requires Admin Approval

Common Errors

PSC9

Cause

Your AAD tenant has been found, but your tenant-policy won’t let you agree to allow PSC access to your company profile.

Note: This could be due to the permissions set by your IT department. You need to contact your IT department to ask them to enable your tenant.

Resolution

You must get in touch with an Azure admin within your company and have them whitelist
https://partnersales.microsoft.com in your company tenant.

↑ Back to the top


Notes about AAD Federation

AAD Federation is usually used in circumstances where two organizations need to exchange potentially-sensitive information in a compliant manner. If at any point you receive errors B3 or B4:

  • B3 - you have either entered an incorrect password, or Microsoft’s AAD tenant cannot identify an AAD tenant associated to your email-address.
  • B4 - your organization has set up policies which require one of your IT administrators to accept the agreements & permissions that Microsoft requires for federation with the PSC web-application.

↑ Back to the top


Section C: Creating an AAD Tenant for My Company

If you receive a notice that your “account or password is incorrect” you may need to set up an AAD tenant, and then supply cosell@microsoft.com with the new username you generate.

It is best-practice to check with your IT department before creating AAD tenants. You may also want to provide admin access to someone in your IT department after you create the tenant. Work with them using this link, & make sure to add them with the role of “Global Admin” under the “Directory Role” setting during step 9 of this process.

Below are the steps to generate a new AAD tenant:

Before you get started, ensure that you have a cellphone nearby for phone number verification and a secondary contact email address to generate a new tenant.

  1. Navigate to https://account.windowsazure.com/organization, and then enter your First & Last name.
  2. Provide a contact email address. Note that you will obtain a username@company.onmicrosoft.com as a result of this procedure, but this is not an email address. You can use it to login to applications which require federation, but you will not be able to receive emails to it by default.
  3. Select a subdomain - for example, if your corporate email address has the suffix contoso.com, try contoso.onmicrosoft.com. If that doesn’t work, you could try contoso1.onmicrosoft.com.
    Note: If you select your company’s domain as the subdomain, notify your IT department.
    Azure1
  4. Once you’ve checked the availability and selected your new <domain-name>.onmicrosoft.com, the form will expand per below. Select a new username for yourself.
  5. Create a password. You’ll use this username/password when logging into https://partnersales.microsoft.com. You can also use these credentials to login to https://portal.azure.com where you can manage the tenant you have created.
  6. When creating an AAD tenant, you must validate your identity with a working phone number as an extra layer of security. If you can text from your phone of choice, enter your number and press the “Send text message” icon. If not, select the “CALL ME” option above the phone-number field & perform the other steps mentioned.
    Enter the code you receive and press “continue.”
    Azure2
  7. At this point you will be redirected to https://portal.azure.com, and you could be asked if you want to create a new Azure Trial Subscription.
    Note: You do not need to sign up for a free Azure Trial Subscription.

    Azure3
  8. You should test the new login credentials you have just created. Close all open InPrivate/Incognito browser-windows and then open a new InPrivate/Incognito window.
  9. Navigate to https://portal.azure.com and enter the <username>@<example>.onmicrosoft.com / password you just generated and make sure to select “Work or School account” if prompted.
  10. You will be able to access the dashboard once you have completed the previous steps successfully.
  11. Send an email to cosell@microsoft.com asking to swap out your email address for the new username@yourdomain.onmicrosoft.com you just created. If you do not proceed with this step, you will receive an error that is similar to B1.
  12. Wait for a confirmation from cosell@microsoft.com that your email has been successfully updated and then go back to Section A.
  13. User Management Instructions for Adding/modifying User Roles for your company’s account.
  14. Complete Partner Sales Connect (PSC) documentation can be found here.

↑ Back to the top


Keywords: helppartner, partner center sales connect, vkb265, get support, programs and membership

↑ Back to the top

Article Info
Article ID : 4486910
Revision : 49
Created on : 8/1/2019
Published on : 8/1/2019
Exists online : False
Views : 254