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Timeline does not render and shows "Records could not be loaded"


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Symptom

Timeline in UCI does not render displaying the following error: "Records could not be loaded because of an unexpected error". This looks like this:

Timeline does not render displaying

If you open the developer tools and refresh the page, you will see in the Networking tab a "batch" request that contains a GET call to /api/data/v9.0/activitypointers/Microsoft.Dynamics.CRM.RetrieveTimelineWallRecordshas that has failed with 400 - Bad Request (the failed request will be in red) and this message:

{"error":{"code":"0x8004430d","message":"Number of link entities in query exceeded maximum limit.","innererror":{"message":"Number of link entities in query exceeded maximum limit."

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Cause

This is a limitation of the timeline control which our team is addressing right now. There is a QueryLinkEntityLimit setting and going over that limit results in the error. Link-entities come both from out-of-the-box activities as well as custom activities.

Customers can add extra link-entities to that call by doing the following customization to the timeline: using card forms for custom activities.

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Mitigation

Mitigation 1

You can contact the customer support and provide the details about this error and ask them to increase the QueryLinkEntityLimit setting for your organization.

Note: This setting will affect all calls in the organization that have link-entities and might decrease performance for calls that have very high link-entity count. However, the performance hit should not be significant if we are increasing the limit by a single digit.

Mitigation 2

If the customer has created custom activities and is using card forms for them, they can disable the card forms in order to reduce the number of link-entities in the batch request. This can be achieved by doing the following steps:

  1. Go to the Timeline settings for UCI (on the form editor of the entity with issues, double click on the timeline section and the settings should open).
  2. In the Activities tab, Additional Options section, look for all custom activities that have a card form.
  3. Change the selection to 'Select Card Form' - this will disable the card form.

It is also possible to not include a custom activity at all in the timeline if it is not useful:

  1. Go to the Timeline settings for UCI.
  2. In the Activities tab, Filter By section, instead of 'Show all' select 'Show selected'.
  3. Deselect the custom activities that are going to be removed from the timeline.

 

Timeline does not render displaying

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Keywords: dynamics 365

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Article Info
Article ID : 4480001
Revision : 15
Created on : 12/4/2018
Published on : 12/4/2018
Exists online : False
Views : 371