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"Appointments, contacts, and tasks for the mailbox [Mailbox Name] couldn't be synchronized...The system will try again later" warning appears in Dynamics 365


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Symptom

When viewing Alerts for a mailbox in Dynamics 365, you see the following warning:

"Appointments, contacts, and tasks for the mailbox [Mailbox Name] couldn't be synchronized. The owner of the associated email server profile [Profile Name] has been notified. The system will try again later."

The following additional details are also included:

"Error : Exchange Error Code: ErrorIrresolvableConflict

Exchange Error Message : The operation can't be performed because the item is out of date. Reload the item and try again. Exchange Error Details: System.Collections.Generic.Dictionary`2[System.String,System.String]"

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Cause

This warning may appear if Server-Side Sync attempted to update an item in Microsoft Exchange and an ErrorIrresolvableConflict message was returned by the Exchange server. This is typically a temporary issue and the item will be updated successfully during the next synchronization cycle. 

 

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Resolution

If this message does not persist on the next synchronization cycle (typically 15 minutes), this warning can be ignored. If this message persists, you can contact Microsoft Support.

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Keywords: appointment, warning

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Article Info
Article ID : 4470093
Revision : 4
Created on : 11/19/2019
Published on : 11/19/2019
Exists online : False
Views : 329