Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Appointments, contacts, and tasks for the mailbox [Mailbox Name] couldn't be synchronized...The system will try again later" warning appears in Dynamics 365


View products that this article applies to.

Symptom

When viewing Alerts for a mailbox in Dynamics 365, you see the following warning:

"Appointments, contacts, and tasks for the mailbox [Mailbox Name] couldn't be synchronized. The owner of the associated email server profile [Profile Name] has been notified. The system will try again later."

The following additional details are also included:

"Error : Exchange Error Code: ErrorIrresolvableConflict

Exchange Error Message : The operation can't be performed because the item is out of date. Reload the item and try again. Exchange Error Details: System.Collections.Generic.Dictionary`2[System.String,System.String]"

↑ Back to the top


Cause

This warning may appear if Server-Side Sync attempted to update an item in Microsoft Exchange and an ErrorIrresolvableConflict message was returned by the Exchange server. This is typically a temporary issue and the item will be updated successfully during the next synchronization cycle. 

 

↑ Back to the top


Resolution

If this message does not persist on the next synchronization cycle (typically 15 minutes), this warning can be ignored. If this message persists, you can contact Microsoft Support.

↑ Back to the top


Keywords: appointment, warning

↑ Back to the top

Article Info
Article ID : 4470093
Revision : 4
Created on : 11/19/2019
Published on : 11/19/2019
Exists online : False
Views : 322