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"We can’t load this app because your email account isn’t configured with Dynamics 365 server-side sync for appointments, contacts, and tasks..." error occurs in Dynamics 365 App for Outlook


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Symptom

When attempting to open the Dynamics 365 App for Outlook, you encounter the following error:

"We're sorry

We can’t load this app because your email account isn’t configured with Dynamics 365 server-side sync for appointments, contacts, and tasks. Ask your system administrator to set up server-side sync for appointments, contacts, and tasks."

If you click Show more, you see additional details such as the following:

"Error: Email account isn’t configured with server-side sync for appointments, contacts, and tasks Trace: Error: Email account isn’t configured with server-side sync for appointments, contacts, and tasks"

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Cause

The Dynamics 365 App for Outlook requires Server-Side Synchronization to be enabled for your mailbox. This error occurs when your mailbox in Dynamics 365 is not enabled for synchronization of Appointments, Contacts, and Tasks using Server-Side Synchronization. 

NOTE: Your mailbox may have had Server-Side Synchronization configured correctly before. However, if the status of your mailbox in Dynamics 365 changes later to a failure status, you would encounter this error until the mailbox is correctly configured and enabled again.

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Resolution

Verify your mailbox is enabled for incoming email with Server-Side Synchronization.

  1. Access Dynamics 365 as a user with the System Administrator role.
  2. Navigate to Settings and then click Email Configuration
  3. Click Mailboxes and then change the view to Active Mailboxes
  4. Locate and open the mailbox record for the user encountering the error.
  5. Verify the Appointments, Contacts, and Tasks option is set to Server-Side Synchronization or Email Router
  6. If the Appointments, Contacts, and Tasks Status does not already show as Success, click Test & Enable Mailbox and make sure to select the checkbox that appears in the dialog. 
  7. If the mailbox tests do not succeed, review the messages in the Alerts section. If an alert includes a Learn More link, click this link for additional details. If you continue to see failures after clicking Test & Enable Mailbox, click here for additional guidance.
  8. After the mailbox shows Success for Appointments, Contacts, and Tasks Status, close and reopen Outlook. Then try to open the Dynamics 365 App for Outlook again.
  9. If this message continues to appear after the mailbox is successfully Tested & Enabled and you closed and reopened Outlook, this could occur if the user is a member of multiple Dynamics 365 instances and the app was deployed from some other instance where the mailbox is not Tested & Enabled. 

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Additional Information

If this message continues to appear after the mailbox is successfully Tested & Enabled and you closed and reopened Outlook, this could occur if the user is a member of multiple Dynamics 365 instances and the app was deployed from some other instance where the mailbox is not Tested & Enabled.

Example: Your organization has multiple Dynamics 365 instances such as an instance for production (Instance A) and another for testing (Instance B). If you enabled the mailbox for Server-Side Sync in Instance A but are still seeing this message, it could be because the app was last deployed to this user's Exchange mailbox from Instance B.

If this may be the cause, follow these steps:

  1. Open the web application for instance that the user will be using for their connection to Dynamics 365.
  2. Navigate to Settings area and click Dynamics 365 App for Outlook.
  3. Select the user from the All Elligible Users list.
  4. Click the Add App to Outlook button.
  5. The Status should switch to Pending. In about 15 minutes the app should be redeployed to this user's mailbox and be connected to this instance.

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Keywords: email, error, load, tasks, contacts, Outlook, account, app, dynamics 365, 80061217, appointments

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Article Info
Article ID : 4469522
Revision : 5
Created on : 4/26/2019
Published on : 4/26/2019
Exists online : False
Views : 259