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HP devices may experience blue screen error WDF_VIOLATION after installing HP keyboard driver (version 11.0.3.1)


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Summary

In working with HP, Microsoft has identified an HP driver with known incompatibility with certain HP devices on Windows 10 versions 1803 and 1809.  On October 11, Microsoft removed the driver from Windows Update to reduce the number of devices affected. Additionally, we have released KB 4468304 to remove the incompatible driver from devices pending reboot. HP is actively working on this issue. 

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Symptoms

After installing the HP keyboard driver (version 11.0.3.1), via Windows Update or manually, HP devices may experience a blue screen error: WDF_VIOLATION.

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Cause

This driver has a known incompatibility with certain HP devices on Windows 10 versions 1803 and 1809.

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Resolution

Scenario 1 Windows Update has installed the driver and a restart is pending

If Windows Update has installed the HP keyboard driver (version 11.0.3.1), and you are pending a restart, do not restart your device. We have released an update that will remove the incompatible driver from your device via Windows Update. Alternatively, you can uninstall the driver manually.

Install KB 4468304 to remove the HP Keyboard driver (version 11.0.3.1)

Microsoft will automatically download KB 4468304 to remove the faulty HP driver via Windows Update. You can also install the KB manually via Microsoft Update Catalog.

How to determine if the HP Keyboard driver has been removed

  1. Start Device Manager. In the Search box, type Device Manager.
  2. Scroll down for Keyboards and expand.
  3. See if the HP keyboard driver (version 11.0.3.1) is still present.

Uninstall the HP Keyboard driver manually

  1. Start Device Manager. In the Search box, type Device Manager
  2. Expand Keyboards and locate your HP keyboard and select Properties.
  3. Select the Driver tab, confirm you have HP keyboard driver (version 11.0.3.1) and then select Roll Back Driver.

 

Scenario 2 – You receive a bluescreen error: WDF_VIOLATION

If your HP device is experiencing a blue screen error: WDF_VIOLATION and fails to load the Windows operating system, following the instructions below to recover your system:

Start the Windows 10 Recovery Environment.

If the device fails to start, Windows should attempt to automatically repair your device and enter the Windows 10 Recovery Environment.

If Windows will not attempt an automatic repair, you will need to use installation media to enter the Windows 10 Recovery Environment:

How to create and use installation media to load the Recovery Environment 
  • On a working PC, go to the Microsoft software download website.
  • Download the media creation tool and then run it.
  • Select Create installation media for another PC.
  • Choose a language, edition, and architecture (64-bit or 32-bit).
  • Follow the steps to create installation media, and then select Finish.
  • Connect the installation media you created to your nonfunctional PC, and then turn it on.
  • On the initial setup screen, enter your language and other preferences, and then select Next. If you're not seeing the setup screen, your PC might not be set up to boot from a drive. Check your PC manufacturer's website for info on how to change your PC's boot order, and then try again.
  • Select Repair your computer.

 

Uninstall the update using Command Prompt

  • At the repair screen in the Recovery Environment, select Troubleshoot, then Advanced Options, and then Command Prompt. You may be asked to enter a BitLocker Recovery Key or username/password.  If prompted for a username/password, you must enter a local administrator account.
  • In the Command Prompt window, type the command listed below for your version of Windows and press ENTER.

For 32-bit versions of Windows:

dism /Image:C\ /Remove-Driver /Driver: C:\Windows\System32\DriverStore\FileRepository\hpqkbfiltr.inf_x86_f1527018cecbb8c2\HpqKbFiltr.inf

For 64-bit versions of Windows:

dism /Image:C:\ /Remove-Driver /Driver:c:\Windows\System32\driverstore\FileRepository\hpqkbfiltr.inf_amd64_714aca0508a80e9a\HpqKbFiltr.inf

Note: If Windows is not stored on the C: drive, replace the C: in the above commands with the appropriate drive letter.

Exit the Recover Environment

  • Click Continue to exit the Recovery Environment and then restart Windows.

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Article Info
Article ID : 4468372
Revision : 18
Created on : 10/19/2018
Published on : 10/19/2018
Exists online : False
Views : 581