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Incorrect caller ID is shown on the Skype for Business client in a call-forwarding scenario


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Symptoms

Consider the following scenario:

  • You implement a third-party SIP-Trunk integration solution such as Cisco, Avaya Aura and so on, with Microsoft Skype for Business Server 2015.
  • You are an enterprise voice (EV) enabled Skype for Business user. User B and User C are using the Cisco or Avaya phone.
  • User C has a call forwarding to User B.

  • You make a telephone call with User C by using the Skype for Business client.

  • The call connection is established between you and User B.

In this scenario, you may see the Skype for Business client displays the User C's caller ID (also known as a Calling Line ID) instead of User B's caller ID.

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Cause

This issue occurs because the information about the original caller is lost at the Skype for Business Mediation server.

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Resolution

To fix this issue, install the January 2019 cumulative update 6.0.9319.537 for Skype for Business Server 2015, Mediation Server.

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More information

After you apply this update, you have to set the AcceptGatewayPAIForOutboundCalls parameter (this value is false by default) to true to display forwarded number for different trunks. For example:

Set-CsTrunkConfiguration -Identity site:Redmond -AcceptGatewayPAIForOutboundCalls $True

This example modifies a trunk configuration with the Identity site:Redmond to enable the AcceptGatewayPAIForOutboundCalls. The remaining properties for this configuration will keep their existing values.

Third-party information disclaimer

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Keywords: kb, kbfix, kbqfe, kbsurveynew, kbexpertiseadvanced, Incorrect caller ID shown, in a call-forwarding in Skype for Business

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Article Info
Article ID : 4458692
Revision : 12
Created on : 12/19/2018
Published on : 1/8/2019
Exists online : False
Views : 189