Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"The account does not have permission to impersonate the requested user" error occurs when clicking Test Connection in Microsoft Dynamics 365


View products that this article applies to.

Symptom

When you click Test Connection on an email server profile to connect Dynamics 365 Online to Exchange on-premises, you encounter the following error:

"The account does not have permission to impersonate the requested user"

↑ Back to the top


Cause

This error can appear if the user account specified in the Email Server Profile record does not have impersonation permissions for the Exchange mailbox. 

↑ Back to the top


Resolution

Make sure the user account provided in the Email Server Profile record has impersonation permissions to each associated Exchange mailbox.  
For more information on configuring Exchange impersonation, see:

How to: Configure impersonation

Impersonation and EWS in Exchange

↑ Back to the top


Keywords: Server-Side Synchronization, email, impersonation, test connection

↑ Back to the top

Article Info
Article ID : 4295275
Revision : 5
Created on : 5/18/2018
Published on : 5/18/2018
Exists online : False
Views : 256