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"The account does not have permission to impersonate the requested user" error occurs when clicking Test Connection in Microsoft Dynamics 365


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Symptom

When you click Test Connection on an email server profile to connect Dynamics 365 Online to Exchange on-premises, you encounter the following error:

"The account does not have permission to impersonate the requested user"

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Cause

This error can appear if the user account specified in the Email Server Profile record does not have impersonation permissions for the Exchange mailbox. 

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Resolution

Make sure the user account provided in the Email Server Profile record has impersonation permissions to each associated Exchange mailbox.  
For more information on configuring Exchange impersonation, see:

How to: Configure impersonation

Impersonation and EWS in Exchange

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Keywords: Server-Side Synchronization, email, impersonation, test connection

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Article Info
Article ID : 4295275
Revision : 5
Created on : 5/18/2018
Published on : 5/18/2018
Exists online : False
Views : 412