Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

KB 4132654: Payroll timecard approvals are not going to correct approver in Microsoft Dynamics GP


View products that this article applies to.

SYMPTOM

ESS Employee Payroll timecard approvals are not going to correct approver in Microsoft Dynamics GP, or skipping direct managers.

↑ Back to the top


CAUSE

Workflow will route to the manager defined in Active Directory, not the superviser ID assigned to the Employee in Dynamics GP on the Employee Maintenance card. 

Note:  If someone else resubmits a workflow, the system would consider the Windows user login on that machine as the requestor. 

If the system is unable to find the approver, it will be routed to the workflow manager by default. 

↑ Back to the top


RESOLUTION

Workflow 2.0 is driven by Active Directory the supervisor field in Payroll is not used in this process.  The manager that will be used for workflow is the ‘Manager’ listed in Active Directory under the ‘Organization’ tab of the user, when you click ‘Properties’.   You may need to add the managers in active directory, not on the supervisor of the employee.  

Here is a blog article that explains how this process works as well.  

Employee to Direct Manager Workflow 2.0: How it works  

 

 

 

query words:  employee self service self-service timecards workflow gp approver approvers not correct manager 

↑ Back to the top


Keywords: kb, kbMBSMigrate, gp, kbmbspartner, kbinternal, kbtshoot

↑ Back to the top

Article Info
Article ID : 4132654
Revision : 7
Created on : 4/13/2018
Published on : 4/13/2018
Exists online : False
Views : 296