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"An error occurred in sending email for mailbox" warning appears when testing and enabling a mailbox in Dynamics 365


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Symptom

When you attempt to test and enable a mailbox in Microsoft Dynamics 365, you encounter the following error:

"An error occurred in sending email for mailbox "Your mailbox is now connected to Dynamics 365" while connecting to the email server. The owner of the associated email server profile <Mailbox Name> has been notified. The system will try to send email again later.

Email Server Error Code: Web server returned ConnectFailure exception."

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Cause

This error can occur if Dynamics 365 is unable to connect to your email server.

If you are usind Dynamics 365 Online with Exchange on-premises, this can occur if your firewall does not allow communication from Dynamics 365 online. 

If you are using an SMTP/POP3 provider such as Gmail, this can occur if the the port values within the Advanced section of the email server profile are not correct.

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Resolution

Dynamics 365 Online with Exchange on-premises

Verify your firewall allows communication from Dynamics 365 online. For a list of the IP address ranges that may be used by Dynamics 365, see Microsoft Dynamics CRM Online IP Address Ranges

POP3/SMTP Providers such as Gmail

Verify the correct ports are specified:

1. Navigate to Settings, Email Configuration, and then click Email Server Profiles.

2. Open the Email Server Profile that is used by the mailbox encountering this error.

 

3. Click Advanced.

4. Verify the Incoming Port and Outgoing Port values and then click Save.

 

5. Click Mailboxes and then select the mailbox that encountered the error.

6. Click the Test & Enable Mailboxes button.

7. After the tests complete, open the mailbox record and view the Alerts section if the results do not appear as Success.

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Article Info
Article ID : 4092737
Revision : 4
Created on : 8/9/2018
Published on : 8/9/2018
Exists online : False
Views : 286