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"A general mailbox access error occurred while receiving email" error appears when testing and enabling a mailbox in Dynamics 365


When you attempt to test and enable a mailbox in Microsoft Dynamics 365, you encounter the following error:

"A general mailbox access error occurred while receiving email. Mailbox <Mailbox Name> didn't synchronize. The owner of the associated email server profile <Profile Name> has been notified.

Email Server Error Code: Socket returned exception TimedOut."

If you click the Details section, you may also see addition details such as the following text:

"Error : System.Net.Sockets.SocketException (0x80004005): A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond <IP Address><Port>

   at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
   at Microsoft.Crm.Asynchronous.EmailConnector.Pop3Client.Connect()"

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Cause

This error can occur if the port values within the Advanced section of the email server profile are not correct.

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Resolution

1. Navigate to Settings, Email Configuration, and then click Email Server Profiles.

2. Open the Email Server Profile that is used by the mailbox encountering this error.

 

3. Click Advanced.

4. Verify the Incoming Port and Outgoing Port values and then click Save.

 

5. Click Mailboxes and then select the mailbox that encountered the error.

6. Click the Test & Enable Mailboxes button.

7. After the tests complete, open the mailbox record and view the Alerts section if the results do not appear as Success.

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Keywords: mailbox, Server-Side Sync, timeout, SocketException, Socket, Pop3

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Article Info
Article ID : 4092736
Revision : 2
Created on : 3/2/2018
Published on : 3/2/2018
Exists online : False
Views : 123