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“Sorry, something went wrong while initializing the app.” when accessing the Dynamics 365 App for Outlook


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Symptom

When you click the Dynamics 365 app in Outlook (anywhere the app is supported) and your Dynamics 365 (online) instance is version 9.x, you see the following message:

“Sorry, something went wrong while initializing the app. Please try again, or restart the app”

When you click View More, you see the following additional details:

"Error: AppforOutlookModule was not found, empty appId returned Trace: Error: AppforOutlookModule was not found, empty appId returned at ..."

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Cause

This can occur if you have a custom Dynamics 365 security role assigned and the role does not have access to the Dynamics 365 App for Outlook app module.

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Resolution

If you are using a custom security role, refer to the following documentation for how to grant the role access to the Dynamics 365 App for Outlook app module:

https://docs.microsoft.com/dynamics365/customer-engagement/outlook-app/deploy-dynamics-365-app-for-outlook#provide-security-role-access

After verifying all required privileges, close and reopen Outlook.

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Article Info
Article ID : 4078135
Revision : 5
Created on : 8/13/2018
Published on : 8/13/2018
Exists online : False
Views : 306