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An error occurred while creating the incoming email in Microsoft Dynamics 365


View products that this article applies to.

Symptom

The following alert is logged within a mailbox record in Microsoft Dynamics 365:

"An error occurred while creating the incoming email <Email Subject> in Microsoft Dynamics 365 for the mailbox <Mailbox Name>."

If you click View Details within the alert, you see the following additional information:

"Email Server Error Code: InvalidSender"

or:

"Email Server Error Code: InvalidForwardMailItem"

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Cause

Cause 1:

If the alert includes the text "InvalidSender", this message is logged if Server-Side Synchronization could not track an email because there was not a valid email address in the From field of the message.

Cause 2:

If the alert includes the text "InvalidForwardMailItem", this message is logged if a Forward Mailbox received the email but the Dynamics 365 mailbox that forwarded the email to the Forward Mailbox either did not correctly forward the email as an attachment or that mailbox does not have the Incoming Email option set to the Forward Mailbox option.

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Resolution

Solution 1 (InvalidSender):

1. Locate the corresponding email in the mailbox.

2. Verify there is a valid email address in the From field.

Solution 2 (InvalidForwardMailItem):

1. Open the Dynamics 365 mailbox record that forwarded the email to the Forward Mailbox.

2. Verify the Incoming Email setting, located within the Synchronization Method section, has the Forward Mailbox option selected. If another option such as Server-Side Synchronization or Email Router is selected, that would explain why this error is logged. 

3. If the mailbox was already configured to use the Forward Mailbox option for Incoming Email, verify the mailbox is correctly configured to not just forward emails to the Forward Mailbox but that it is configured to forward the emails as an attachment. 

 

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More Information

Some applications send automated emails that do not include a valid email address in the From field. For example, the Clutter feature in Outlook sends messages that result in the following informational alert:

"An error occurred while creating the incoming email "Clutter moved new and different messages" in Microsoft Dynamics 365 for the mailbox"

This alert can safely be ignored and is an information level alert. If you want to avoid logging of information level alerts, you can change which types of alerts are enabled within System Settings.

  1. As a user with the System Administrator role, navigate to Settings, click Email Configuration, and then click Email Configuration Settings.
  2. Scroll down to the Configure alerts section and remove the selection from the Information checkbox.
  3. Click OK

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Keywords: InvalidSender

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Article Info
Article ID : 4053783
Revision : 11
Created on : 4/3/2020
Published on : 4/3/2020
Exists online : False
Views : 265