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Your mailbox can't sync incoming emails because the email connection channel is set to sync using an Email Router


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Symptom

When you attempt to Test and Enable a mailbox in Dynamics 365, one of the following alerts are logged:

  • "Your mailbox <Mailbox Name> can't sync incoming emails because the email connection channel is set to sync using an Email Router. Contact your administrator to change the default connection channel to Server-Side Synchronization.

      Email Server Error Code: IncomingEmailConnectionChannelError"

  • "Your mailbox <Mailbox Name> can't sync outgoing emails because the email connection channel is set to sync using an Email Router. Contact your administrator to change the default connection channel to Server-Side Synchronization.

      Email Server Error Code: OutgoingEmailConnectionChannelError"

  • "Your mailbox <Mailbox Name> can't sync appointments, contacts, and tasks because the email connection channel is set to sync using an Email Router. Contact your administrator to change the default connection channel to Server-Side Synchronization.

      Email Server Error Code: ExchangeSyncACTEmailConnectionChannelError"

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Cause

These alerts are logged if the Process Email Using option within System Settings is configured to use "Microsoft Dynamics 365 Email Router" instead of "Server-Side Synchronization".

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Resolution

To use Server-Side Synchronization instead of Email Router, make sure the Process Email Using option within System Settings is configured to use Server-Side Synchronization:

1. Access your Dynamics 365 instance as a user with the System Administrator role.

2. Navigate to Settings and then click Administration.

3. Click the Email tab. 

4. Locate the Process Email Using option and make sure it is set to Server-Side Synchronization.

5. Click OK.

6. Navigate to Settings and then click Email Configuration.

7. Click Mailboxes.

8. Change the selected view from My Active Mailboxes to Active Mailboxes

9. Select the mailboxes you want to enable for Server-Side Synchronization and then click the Test & Enable Mailboxes button. Make sure to select the checkbox on the dialog that appears and then click OK.

10 Wait for the Test & Enable process to complete. If the test results are not Success, review the Alerts area within the mailbox record.

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More Information

You can only use Email Router or Server-Side Synchronization (recommended) for sending and receiving email in Dynamics 365. Both options cannot be used in the same Dynamics 365 instance. The Process Email Using option determines which of these options is enabled. The Test & Enable Mailbox button is for use with the Server-Side Synchronization feature. If you are using the Email Router, you do not need to Test & Enable the mailbox.

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Keywords: IncomingEmailConnectionChannelError, OutgoingEmailConnectionChannelError, ExchangeSyncACTEmailConnectionChannelError, Email Router, Server-Side Sync

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Article Info
Article ID : 4053588
Revision : 5
Created on : 11/7/2017
Published on : 11/7/2017
Exists online : False
Views : 317