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FIX: Microsoft BizTalk Adapter for DB2 doesn't connect to DB2 for i V7R2 when client-side connection pooling is enabled


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Symptoms

Microsoft BizTalk Adapter for DB2 intermittently doesn't connect to DB2 for i V7R2. This issue occurs when client-side connection pooling is enabled. When this occurs, the following message is logged in the Application event log:

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Cause

This issue occurs because the Microsoft BizTalk Adapter for DB2 doesn't release connections from the client-side connection pool after the default time-out period.

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More information

After this fix is installed, the Microsoft BizTalk Adapter for DB2 is updated to support a new send port and receive location configuration property that is named Connection Pool Timeout. This property instructs the adapter to clear inactive connections from the connection pool after a specified number of seconds.

This property accepts an integer value. The default value is 60 seconds.

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Resolution

This issue is fixed in Cumulative Update 2 for Host Integration Server 2016.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology Microsoft uses to describe software updates.

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Keywords: kbQFE, kbfix, kbBug, kbExpertiseInter, kbsurveynew, kb

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Article Info
Article ID : 4045841
Revision : 12
Created on : 1/10/2018
Published on : 1/10/2018
Exists online : False
Views : 161