Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Informatica loads fail with connection errors in SQL Server Parallel Data Warehouse


View products that this article applies to.

Symptoms

Informatica loads fail intermittently in Microsoft SQL Server 2008 R2 Parallel Data Warehouse (PDW), Microsoft SQL Server 2012 Parallel Data Warehouse, or Microsoft SQL Server 2016 Parallel Data Warehouse. Additionally, you may receive connection error messages that resemble the following:

 

Note This connection error also affects other connections to PDW. For example, non-Informatica loads and other client connections may be affected.

↑ Back to the top


Cause

This issue occurs due to name resolution failure.

↑ Back to the top


Resolution

To fix this issue, follow these steps:

 
  • Replace SQLCTL01 connections with FQDN.
  • This specific client connects their load server to Microsoft Analytics Platform System (APS) by using InfiniBand.
     
    • Specify the appliance domain as the DNS suffix for the InfiniBand connection.

      Advanced TCPIP Settings
    • The external server only has one network adapter. Use both AD01 and AD02 for DNS servers.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbContentAuto, kbsurveynew, kbtshoot, kbExpertiseAdvanced, connection errors, Informatica

↑ Back to the top

Article Info
Article ID : 4038459
Revision : 17
Created on : 8/22/2017
Published on : 8/22/2017
Exists online : False
Views : 602