Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Lync or Skype for Business client can't be started to join meeting if default browser is Firefox 52 or a later version


View products that this article applies to.

Symptoms

Assume that the default browser is Firefox and its version is greater than or equal to 52. When you try to click a Skype for Business meeting link to join the meeting that's created at an on-premises server, the Skype for Business web client is opened to join the meeting instead of the Skype for Business desktop client.

↑ Back to the top


Cause

This issue occurs because the Netscape Plugin Application Programming Interface (NPAPI) plugin is deprecated in Firefox 52 or a later version. NPAPI is currently used as part of the client detection process for the Lync or Skype for Business client when you join a meeting by clicking a link. When NPAPI is disabled, the webpage can’t determine whether you have the client installed.

↑ Back to the top


Resolution

To fix this issue, install the December 2017 cumulative update 6.0.9319.510 for Skype for Business Server 2015, Web Components Server.

Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: kb, kbfix, kbsurveynew, kbexpertiseAdvanced, skype for business can't join meeting

↑ Back to the top

Article Info
Article ID : 4036619
Revision : 11
Created on : 12/6/2017
Published on : 12/11/2017
Exists online : False
Views : 203