Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Business Rules (Portable Business Logic) may not function correctly or may generate errors when a user runs Business Process Flows if the user does not have sufficient privileges on the "Process" entity.


View products that this article applies to.

Symptom

Business Rules fail to execute or Business Process Flows show an error message that begins with “Web Service Plug-in failed in SdkMessageProcessingStepId: (…)”

↑ Back to the top


Cause

If a user’s security role has insufficient privileges on the “Process” entity, which refers to the internal Workflow table, Business Rules and Business Process Flows will fail to generate, load, and execute properly on first load, causing unexpected behavior or intermittent errors. When this occurs, the state is cached, and a subsequent user, whose security role has sufficient privileges tries to load and execute the same Business Rules and Business Process Flows, will experience failure.

To check for access levels, go to Settings > Security > Security Roles > select a security role > Customization tab > Process entity. The Read column should be full green (Organization-level access).

↑ Back to the top


Resolution

1. Make sure all security roles have full Organization-level read privileges for the Process entity
2. Publish the customizations by going to Settings > Customization > Customize the System

↑ Back to the top


Keywords: business rules, privileges, security, process entity, process, pbl, bpf, business process flow

↑ Back to the top

Article Info
Article ID : 4025533
Revision : 4
Created on : 6/7/2017
Published on : 6/7/2017
Exists online : False
Views : 254