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GeneralIncomingEmailServerError when attempting to install Dynamics 365 App for Outlook


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Symptom

When you attempt to install Dynamics 365 App for Outlook, you encounter the following error:

"There was an issue when attempting to add the app to Outlook.

SoapException : GeneralIncomingEmailServerError"

If you click the Details link, the following additional details appear:

"Error : System.Web.Services.Protocols.SoapException: The specified server version is invalid. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult) at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndInstallApp(IAsyncResult asyncResult) at Microsoft.Crm.Asynchronous.EmailConnector.OfficeAppsDeploymentStep.EndCall() at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()"

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Cause

This error can occur if you are using Exchange on-premises and the version does not meet the requirements.

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Resolution

Verify the version of Exchange on-premises you are using meets the requirements documented in the following article:


Deploy Dynamics 365 App for Outlook: Requirements

Refer to the "Supported configurations with Microsoft Exchange" section. 
 

 

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Keywords: Dynamics 365 App for Outlook, server version, invalid, GeneralIncomingEmailServerError, SoapException

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Article Info
Article ID : 4019040
Revision : 5
Created on : 11/15/2018
Published on : 11/15/2018
Exists online : False
Views : 309