Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Virtual Disk GUI in Server Manager displays no Layout and "UNKNOWN" Provisioning with tiered virtual disks in Windows Server 2016 and Windows Server Version 1709


View products that this article applies to.

Symptoms

When you create tiered virtual disks in Windows Server 2016 or Windows Server Version 1709, the Virtual Disks GUI in Server Manager displays an empty or blank status type in the Layout column and an UNKNOWN in the Provisioning column.

Also, if you run the Get-VirtualDisk | fl PowerShell cmdlet, the result lists no configuration for ProvisioningType and ResiliencySettingName. These fields are blank in the PowerShell output.
 
For example, assume that you create a virtual disk that has the following parameters:
 
  • Create storage tiers on this virtual disk is checked.
  • Storage Layout is Mirror.
  • Provisioning Type is Fixed.
You expect the Get-VirtualDisk | fl PowerShell cmdlet to include these values in the output.
 
ProvisioningType : Fixed
ResiliencySettingName : Mirror

↑ Back to the top


Cause

Multi-resilient tiers are supported in Windows Server 2016. Therefore, the provisioning type is tier-specific and will not display for the virtual disk. For the virtual disk, the provisioning and resiliency (layout) properties will be blanked out.

↑ Back to the top


Workaround

To work around this issue, query the storage tier to determine the resiliency and provisioning information. For tiered virtual disks, use the following cmdlet:

Get-VirtualDisk -FriendlyName "Name of virtual disk" | Get-StorageTier | fl

For non-tiered virtual disks use the Get-VirtualDisk | fl cmdlet.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbbug, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 4015969
Revision : 15
Created on : 10/4/2017
Published on : 10/18/2017
Exists online : False
Views : 481