Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Calls to RGS may fail after an in-place upgrade from Lync Server 2013 to Skype for Business Server 2015


View products that this article applies to.

Symptoms

The Response Group Service (RGS) service fails to start after an in-place upgrade from Microsoft Lync Server 2013 to Microsoft Skype for Business Server 2015 when you apply the May 2017 cumulative update 6.0.9319.281 in certain situations.

↑ Back to the top


Cause

In Skype for Business Server 2015, the default design is changed to use three Presence Watcher contact objects (instead of one Presence Watcher contact object in earlier versions). The service startup failure is introduced to prevent an issue in which the service has started, but calls to RGS fail with "500 Internal Server error", because only one Presence Watcher contact object is found after the start of the RGS service.

↑ Back to the top


Resolution

To fix this issue, republish the topology, wait for AD Replication to finish (to make sure that all three contact objects can be accessible by RGS when it starts). Restart just the RGS service on every Front-End in the pool.

↑ Back to the top


More Information

After you install this update, the RGS service won't start until all RGS contact objects are created. The contact objects include one Announcement Service and three RGS Presence Watcher contact objects in a Skype for Business Server 2015 pool.

The event ID 31067 will be updated to reflect the "republish the topology and restart just the RGS service" text in the resolution section.

↑ Back to the top


Keywords: kb, kbsurveynew, kbexpertiseAdvance, kbfix, kbqfe

↑ Back to the top

Article Info
Article ID : 4015901
Revision : 7
Created on : 5/12/2017
Published on : 5/17/2017
Exists online : False
Views : 272