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Mailbox requires an approval by an Office 365 administrator


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Symptom

After you click the Test & Enable Mailbox button on a mailbox record in Dynamics 365 (online), you encounter one of the following error alerts:

  • Email cannot be received because the email address of the mailbox <Mailbox Name> requires an approval by an Office 365 administrator. The mailbox didn't synchronize. A notification about this is posted on the alerts wall for the owner of the email server profile Microsoft Exchange Online.
  • Email cannot be sent because the email address of the mailbox <Mailbox Name> requires an approval by an Office 365 administrator. The mailbox didn't synchronize. The owner of the email server profile Microsoft Exchange Online has been notified.
  • Appointments, contacts, and tasks can't be synchronized because the email address of the mailbox <Mailbox Name> requires an approval by an Office 365 administrator. A notification about this is posted on the alerts wall for the owner of the email server profile Microsoft Exchange Online.
You may also see the following notification within the mailbox record:
 
"Email won't be processed for this mailbox until the email address of the mailbox is approved by an Office 365 administrator. For more information, contact your system administrator."
 
 

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Cause

When using Dynamics 365 (online) with Exchange Online, the email address for a mailbox record needs to be approved by an Office 365 user with the Global Administrator or Exchange Administrator role.

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Resolution

1. Sign into Dynamics 365 (online) as a user with the following privileges:
  • Global Administrator or Exchange Administrator role in Office 365
  • System Administrator role in Dynamics 365

2. Navigate to Settings and then click Email Configuration.

3. Click Mailboxes.

4. Change the view from my My Active Mailboxes to Active Mailboxes.

5. Select the mailbox and then click the Approve Email button.

6. After the mailbox is approved, you can select the mailbox and then click the Test & Enable Mailboxes button.

NOTE: If the test results are something other than success, you can open the mailbox record and click the Alerts section. View the details of any errors that were logged.

For more information on recent changes to approval requirements including how to disable this requirement, refer to the following article:

https://support.microsoft.com/help/4506139

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More Information

For more information on the Global Administrator and Exchange Administrator roles and assigning admin roles in Office 365, refer to the following resources:
 

About Office 365 admin roles
Assign admin roles in Office 365

 

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Keywords: server-side synchronization, approval, exchange online, Dynamics 365

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Article Info
Article ID : 4014483
Revision : 7
Created on : 6/11/2019
Published on : 6/11/2019
Exists online : False
Views : 540