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The SMTP Message Screener may not filter some messages correctly in ISA Server 2000


View products that this article applies to.

This article was previously published under Q331061

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Symptoms

When you use the Internet Security and Acceleration (ISA) Server 2000 Simple Mail Transfer Protocol (SMTP) Message Screener to filter e-mail messages, the SMTP Message Screener may not filter some messages correctly.

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Cause

This problem occurs if the ISA Server SMTP Message Screener filters multipart messages.

In Microsoft Outlook, e-mail messages and attachments are split into multipart messages if the total size of the message is too large to be sent as a single message. When an e-mail message and an attachment are split into multipart messages, the file names and the file extensions are changed from the original file names and file extensions. Therefore, some of the rules that you created may not function correctly. For example, rules that you created to delete attachments that contain .exe file extensions do not function correctly because the multipart messages are assigned new file extensions. The ISA Server SMTP Message Screener does not detect the original extensions. Therefore, the ISA Server SMTP Message Screener does not filter the messages.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for ISA Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
313139� How to obtain the latest Internet Security and Acceleration Server 2000 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time      Version       Size    File name     Platform
   -------------------------------------------------------------------
   22-Oct-2002  14:25:24  3.0.1200.180  60,176  Fltrsnk1.dll  x86
   22-Oct-2002  14:25:28  3.0.1200.180  93,968  Fmtpfltr.dll  x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in ISA Server 2000 Service Pack 1.

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Keywords: KB331061, kbfix, kbbug, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 331061
Revision : 8
Created on : 6/14/2007
Published on : 6/14/2007
Exists online : False
Views : 402