Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Requests Are Not Removed from ASP.NET Request Table


View products that this article applies to.

This article was previously published under Q329956

↑ Back to the top


Symptoms

During a time of inactivity, the following entry may appear in the Application Event log:
Event Type: Error
Event Source: ASP.NET 1.0.3705.0
Event Category: None
Event ID: 1003
Date: 4/24/2002
Time: 6:18:23 PM
User: N/A
Computer: ComputerName
Description:
aspnet_wp.exe (PID: xxx) was recycled because it was suspected to be in a deadlocked state. It did not send any responses for pending requests in the last 180 seconds.
-or-

You may note that memory consumption has increased in the Inetinfo.exe process.

↑ Back to the top


Cause

The deadlock condition and the increased memory consumption occur because ASP.NET does not remove requests from its internal request table. This occurs because a client has disconnected from the request. The following are a few common actions that might cause a client request to become disconnected:
  • A user closes the browser during a request.
  • A user clicks Stop during a request.
  • A user clicks a link before the page loads completely.
NOTE: This problem occurs when ASP.NET runs under Secure Sockets Layer (SSL). Some ISAPI Filters can cause this problem, also. This problem occurs more frequently on sites that have users who have slow connections.

↑ Back to the top


Resolution

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next .NET Framework service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name
   --------------------------------------------------------------
   02-Oct-2002  23:48  1.0.3705.364    196,608  Aspnet_isapi.dll
   02-Oct-2002  23:40                   19,332  Aspnet_perf.ini
   02-Oct-2002  16:40                   19,206  Aspnet_perf2.ini
   02-Oct-2002  23:48  1.0.3705.364     24,576  Aspnet_regiis.exe
   02-Oct-2002  23:48  1.0.3705.364     28,672  Aspnet_wp.exe
   20-Aug-2002  02:32                       15  Smartnav.htm
   23-Aug-2002  03:23                    8,800  Smartnav.js
   10-May-2002  21:16                    7,003  Smartnavie5.js
   03-Oct-2002  10:58  1.0.3705.364  1,187,840  System.web.dll
				

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


More information

For more information about how to troubleshoot deadlocks in ASP.NET, see the following article in the Microsoft Knowledge Base:
325947� Event ID 1003 with ASP.NET Deadlock

↑ Back to the top


Keywords: KB329956, kbnetframe100presp3fix, kbfix, kbbug, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 329956
Revision : 7
Created on : 10/11/2005
Published on : 10/11/2005
Exists online : False
Views : 464