Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error when pipeline component does not exist


View products that this article applies to.

This article was previously published under Q329516

↑ Back to the top


Symptoms

If a Commerce Server 2002 pipeline references a pipeline component that does not exist or that cannot be created, the pipeline does not run the component, and you may receive the following error message:
Commerce.MtsPipeline error '80040154' Component Execution failed for component(0x0) hr: 0x80040154 ProgID:....Loading Component.....failed because GlobalInterface Table is Unable to provide a valid marshaled interface pointer for the component.
In the application event log, event ID: 4104 appears that has a description similar to the error mesage.

↑ Back to the top


Cause

This problem occurs because the pipeline component does not load any configuration information.

↑ Back to the top


Resolution

To resolve this problem, review the pipelines to determine the point of failure. Open the pipeline in the Pipeline Editor, and then use the Program ID and the component number in the error message to determine the component that is failing.

↑ Back to the top


Status

This behavior is by design.

↑ Back to the top


Keywords: KB329516, kbprb, kberrmsg

↑ Back to the top

Article Info
Article ID : 329516
Revision : 4
Created on : 1/13/2005
Published on : 1/13/2005
Exists online : False
Views : 310