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You receive an "Access is denied" error message in Exchange Server 2003 or a "Setup failed while installing sub-component Doctor Watson.NET" error message in Exchange 2000 Server


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Symptoms

In Microsoft Exchange Server 2003 or in Microsoft Exchange 2000 Server, you experience one or more of the following symptoms.

Symptom 1

When you try to reinstall Microsoft Exchange 2000 Server Service Pack 2 (SP2) or Microsoft Exchange 2000 Server Service Pack 3 (SP3), you receive the following error message:
Setup failed while installing sub-component Doctor Watson.NET with error code 0xC0070005 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again.
If you click Retry, you receive the same error message. If you click Cancel, the Setup program continues to install components. Then, you receive the following error message:
Setup failed while installing sub-component System Attendant service with error code 0xC0070005 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again.
If you click Cancel in response to the repeated error messages, the Setup program finishes running. Then, the Setup program reports errors when the Setup program tries to install the following components:
  • Microsoft Exchange System Management Tools
  • Microsoft Exchange Messaging and Collaboration Services

Symptom 2

When you try to reinstall Exchange 2000 Server SP2 or Exchange 2000 Server SP3, you receive the following error message:
Setup failed while installing sub-component Doctor Watson.NET with error code 0xC0070035 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again.
If you click Retry, you receive the same error message. If you click Cancel, the Setup program continues to install components. Then, you receive the following error message:
Setup failed while installing sub-component System Attendant service with error code 0xC0070035 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again.
If you click Cancel in response to the repeated error messages, the Setup program finishes running. Then, the Setup program reports errors when the Setup program tries to install the following components:
  • Microsoft Exchange System Management Tools
  • Microsoft Exchange Messaging and Collaboration Services

Symptom 3

When you try to create the Exchange System Attendant resource for an Exchange Server 2003 cluster, you receive the following error message:
Access is denied.
Facility: Win32
ID no: c0070005
Microsoft Exchange Cluster Administrator Extension
Additionally, the following text is logged in the Exchange Server Setup Progress.log file:
[09:06:06] Entering ScGetExchangeServicesInstallPathFromRegistry 
[09:06:06] ScGetExchangeServicesInstallPathFromRegistry
(f:\titanium\admin\src\libs\exsetup\exmisc.cxx:4353)

Error code 0XC0070005 (5): Access is denied.

[09:06:06] Leaving ScGetExchangeServicesInstallPathFromRegistry
[09:06:06] ScSetupExchangeVirtualServer
(f:\titanium\admin\src\udog\exsetdata\exsetds.cxx:1422)

Error code 0XC0070005 (5): Access is denied.

[09:06:06] Leaving ScSetupExchangeVirtualServer

Symptom 4

When you try to create the Exchange System Attendant resource for an Exchange Server 2003 cluster, you receive the following error message:
Access is denied.
Facility: Win32
ID no: c0070035
Microsoft Exchange Cluster Administrator Extension
Additionally, the following text is logged in the Exchange Server Setup Progress.log file:
23:30:54] Entering ScGetExchangeServicesInstallPathFromRegistry
[23:30:54] ScGetExchangeServicesInstallPathFromRegistry
(f:\tisp1\admin\src\libs\exsetup\exmisc.cxx:4353)

Error code 0XC0070035 (53): The network path was not found.

[23:30:54] Leaving ScGetExchangeServicesInstallPathFromRegistry
[23:30:54] ScSetupExchangeVirtualServer
(f:\tisp1\admin\src\udog\exsetdata\exsetds.cxx:1527)

Error code 0XC0070035 (53): The network path was not found.

[23:30:54] Leaving ScSetupExchangeVirtualServer

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Cause

These issues may occur if either of the following conditions is true:
  • Remote Registry Service is not running.
  • You restrict remote access to the registry on your Windows-based computer.

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Resolution

To resolve this issue, make sure that Remote Registry Service is running, and then test to determine whether the issue is resolved. If the issue is resolved, do not complete the remaining steps. If the issue is not resolved, use one of the following methods.

Method 1: Remove the registry key that restricts remote access

Remove the registry key that restricts access to the Windows registry from a remote computer. To do this, follow these steps.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg
  3. On the Registry menu, click Export Registry File.
  4. In the File name box, type exported winreg, and then click Save.

    Note: If you later want to restore this registry subkey, you can do so by double-clicking the exported winreg.reg file that you saved.
  5. On the Edit menu, click Delete, and then click Yes to confirm the deletion of the winreg registry subkey.
  6. Quit Registry Editor. Then, reinstall the Exchange 2000 Server service pack, or re-create the System Attendant resource for the Exchange Server 2003 cluster.
If you receive an error message when you try to delete the winreg registry subkey, you may not have the correct permissions to perform this operation. In this case, assign the correct permissions to the Administrator account to allow you to delete this registry key. To do this, follow these steps:
  1. Click Start, click Run, type regedt32 in the Open box, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg
  3. On the Security menu, click Permissions.
  4. Add your administrative account, and then click to select the Full Control check box in the Allow column under Permissions.
  5. Click Apply, and then click OK.
  6. On the Edit menu, click Delete, and then click Yes to confirm the deletion of the winreg registry subkey.
  7. Quit Registry Editor. Then, reinstall the Exchange 2000 Server service pack, or re-create the System Attendant resource for the Exchange Server 2003 cluster.

Method 2: Allow Exchange Server 2003 or Exchange 2000 Server access to the winreg registry subkey

Restore the default permissions to the winreg registry subkey to allow Exchange Server 2003 or Exchange 2000 Server access. To do this, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, click Run, type regedt32 in the Open box, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg
  3. For the Microsoft Windows Server 2003 operating system that is running Exchange Server 2003
    Right-click the subkey, and then click Permissions.

    For the Microsoft Windows 2000 Server operating system that is running Exchange 2000 Server
    On the Security menu, click Permissions.
  4. Click Advanced, and then add the following accounts together with the corresponding permissions to the Permission Entries list:

    For the Windows Server 2003 operating system that is running Exchange Server 2003

    TypeNamePermissionApply to
    AllowAdministrator Full Control This key only
    Allow Administrators Full ControlThis key and subkeys
    Allow Backup Operators Read This key only
    Allow Domain Admins Full Control This key only
    Allow Enterprise Admins Full Control This key only
    Allow EXCHANGE$ Full Control This key only
    Allow Exchange Domain Servers Read This key only
    AllowLOCAL SERVICE ReadThis key and subkeys

    For the Windows 2000 Server operating system that is running Exchange 2000 Server

    TypeNamePermissionApply to
    AllowAdministrator Full Control This key only
    Allow Administrators Full Control This key only
    Allow Backup Operators Read This key only
    Allow Domain Admins Full Control This key only
    Allow Enterprise Admins Full Control This key only
    Allow EXCHANGE$ Full Control This key only
    Allow Exchange Domain Servers Read This key only

    Note To allow Full Control access in Exchange Server 2003, click to select the following check box in the Allow column under Permissions:
    Full Control
    To allow Full Control access in Exchange 2000 Server, click to select the following check boxes in the Allow column under Permissions:
    Query Value
    Set Value
    Create Subkey
    Enumerate Subkeys
    Notify
    Create Link
    Delete
    Write DAC
    Write Owner
    Read Control
    To allow Read access in Exchange Server 2003and in Exchange 2000 Server, click to select the following check boxes in the Allow column under Permissions:
    Query Value
    Enumerate Subkeys
    Notify
    Read Control
  5. Click Apply, and then click OK two times.
  6. Quit Registry Editor. Then, reinstall the Exchange 2000 Server service pack, or re-create the System Attendant resource for the Exchange Server 2003 cluster.

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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

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More information

For more information about how to restrict remote access to the Windows registry, click the following article numbers to view the articles in the Microsoft Knowledge Base:
153183 How to restrict access to the registry from a remote computer
186433 Clarification of Winreg operation in Windows NT

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Keywords: KB329229, kbbug, kberrmsg

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Article Info
Article ID : 329229
Revision : 5
Created on : 9/3/2013
Published on : 9/3/2013
Exists online : False
Views : 374