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FIX: XLANG Scheduler May Indicate a Failed Condition in Cluster Administrator


View products that this article applies to.

This article was previously published under Q328887

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Symptoms

When BizTalk Server 2000 is running in a properly configured clustered environment, and you move a group from one node to the other, the XLANG Scheduler application may take a long time to go offline. Also, when the application does go offline, it indicates a failed condition in the Administration Microsoft Management Console (MMC) for the cluster. This condition can occur only if an Xlang Scheduler instance is running while the XLANG Scheduler is closing.

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Cause

This problem occurs because when the XLANG Restart Service is shutting down, it creates an XLANG Scheduler System Manager object to call the ShutdownAll method. In the XLANG Scheduler process, the ShutdownAll method succeeds. However, during the shutdown of the XLANG Scheduler, the COM Services Information thread that is running in the XLANG Scheduler process fails when it tries to query the XLANG Restart Service. The error that is returned is 0x80010108 "The object invoked has disconnected from its clients." This error is returned to the Service Control Manager and then to the Cluster Service.

When XLANG Scheduler returns an error to the Service Control Manager, this error causes the cluster Administrator to indicate a failed condition. When this occurs, it does not affect the action of moving the cluster group because the Cluster Service is trying to stop the XLANG Scheduler, anyway. Because the XLANG Scheduler will be stopped, the Cluster Service indicates the error, and then continues the group move.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version      Size     File name      Platform
   -------------------------------------------------------------------
   18-Sep-2002   13:56   2.0.2003.0   28,944   Wfsvcmgr.exe   Intel
				

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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Keywords: KB328887, kbqfe, kbfix, kbbug, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 328887
Revision : 7
Created on : 10/11/2005
Published on : 10/11/2005
Exists online : False
Views : 265