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Public folder routing is enabled before the hierarchy is replicated


View products that this article applies to.

Symptoms

When a new public folder store is brought online, you may notice in the Queue Viewer that the local delivery queue is growing. If the public folder hierarchy is large, the messages in the local queue continue to grow and may take additional time to be delivered. In some cases, the messages may not be delivered. Messages are not queued if the server sending these messages is in a different routing group from the server with the new public folder store.

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Cause

This problem occurs because when a new public folder store is brought online, mail is frequently routed to the server before the hierarchy can replicate. As a result, mail may be delayed or not delivered.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version       Size     File name
------------------------------------------------------
22-Sep-2002  14:49  6.00.00.6329  372,000  Phatcat.dll

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If you install the hotfix only on the server that has the new public folder store, you will not fix the issue. To fix the issue, you must apply the hotfix on all the servers that route the public folder routing messages.

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Workaround

To work around this problem, create a second routing group and move the new server to that group. Set up routing group connectors and let replication occur. After replication has occurred, move the new server back to the original routing group.

To create a second routing group, follow these steps:
  1. Open Exchange System Manager, expand Administrative Groups, and then expand First Administrative Group.
  2. Right-click Routing Groups, and point to New, and then click Routing Group.
  3. Type a name for the new routing group, and then click OK.
  4. Expand First Routing Group, and then click Members.
  5. Drag the server with the new public folder store from the First Routing Group to the routing group that you just created, and then wait for replication to occur.
  6. After replication has occurred, move the server back to its original routing group.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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More information

When the new server is introduced, its distinguished name is added to the msExchOwningPFTreeBL attribute of the administrative group's Folder Hierarchies - Public Folder object in Active Directory.

To configure the number of days that the routing engine bypasses the new public folder store, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Start Registry Editor (Regedt32.exe).
  2. Locate the following key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters
  3. On the Edit menu, click Add Value, and then add the following registry values:

    Value Name: IgnorePFTimeLimit
    Data Type: REG_DWORD
    Radix: DECIMAL
    Value: Number of days the routing engine will ignore the public folder
    Default: 2
  4. Quit Registry Editor.
  5. Restart the Internet Information Services (IIS) Admin service (IISAdmin).

    Note The registry change only takes effect after you restart all IIS services.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
836448 April 2004 Exchange 2000 Server post-Service Pack 3 update rollup

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Keywords: KB328870, kbfix, kbbug, kbqfe, kbexchange2000presp4fix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 328870
Revision : 11
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 310