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PRB: Read-only Csapp.ini Does Not Permit Applications to Be Added in Unpup


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This article was previously published under Q328614

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Symptoms

The site appears to unpup as expected. However, in Commerce Server Manager, no applications are listed in the Applications node of the site, and error messages similar to the following appear in the pup log:
Extracting file(s) from cabinet 'C:\Documents and Settings\rslape\Local
    Settings\Temp\retail_SiteFilesBlob.cab':
   extracting: c:\inetpub\wwwroot\retail\\addrbook.asp
   extracting: c:\inetpub\wwwroot\retail\\addrform.asp
   extracting: c:\inetpub\wwwroot\retail\\basket.asp
   extracting: c:\inetpub\wwwroot\retail\\BDRefresh.asp
   extracting: c:\inetpub\wwwroot\retail\\category.asp
   extracting: c:\inetpub\wwwroot\retail\\confirm.asp
   extracting: c:\inetpub\wwwroot\retail\\crdtcard.asp
   -- Error opening 'c:\inetpub\wwwroot\retail\\csapp.ini' for output
FDICopy() failed: code 11 [User aborted]

Extracting file(s) from cabinet 'C:\Documents and Settings\rslape\Local
    Settings\Temp\retailbizdesk_SiteFilesBlob.cab':
   -- Error opening 'c:\inetpub\wwwroot\retailbizdesk\\500error.asp' for output
FDICopy() failed: code 11 [User aborted]

  Begin: SetBizDeskFlag
FAIL unpack.vbs: CC1 Item cannot be found in the collection corresponding
    to the requested name or ordinal.
  End: SetBizDeskFlag
  Begin: CreateProductCatalogsDir
FAIL unpack.vbs: 3A File already exists
FAIL unpack.vbs: 800700B7
  End: CreateProductCatalogsDir
  Begin: SetLocaleInfo
  End: SetLocaleInfo
					

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Cause

This problem occurs because the Read-only option was selected for the Csapp.ini file before the site was pupped.

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Resolution

To resolve this problem, follow these steps:
1.Follow the typical steps to unpup the site.
2.When the unpup process is completed, in the site folder and the BizDesk folder, right-click the Csapp.ini file, and then click Properties. Click to clear the Read-only check box, and then click OK.
3.Click Commerce Sites, and then click the site name.
4.Right-click the site.
5.Click Add an application.
6.Select the same pup file.
7.Finish the unpup wizard.

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More information

Steps to Reproduce the Behavior

To reproduce the problem, follow these steps:
1.Unpup the Retail site.
2.In both the Retail folder and the RetailBizDesk folder, right-click the Csapp.ini file, click Properties, click to select the Read-only check box, and then click OK.
3.Pup the site as a new pup.
4.Unpup the new pup file.

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Keywords: KB328614, kbprb, kberrmsg

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Article Info
Article ID : 328614
Revision : 2
Created on : 9/24/2002
Published on : 9/24/2002
Exists online : False
Views : 295