Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Lb*.tmp Files Are Created in the TEMP Folder and Are Not Deleted


View products that this article applies to.

Symptoms

Exchange 2000 Server may temporarily create Lb*.tmp files in the %SYSTEMROOT%\TEMP folder. By default, this is the c:\WINNT\TEMP folder. The Lb*.tmp files are each 256 kilobytes (KB).

↑ Back to the top


Cause

This issue may be caused if either of the following conditions exist:
  • Very large files are streamed into or out of the Exchange Information Store.
  • The .stm file is highly fragmented.
Typically, these files are automatically deleted from the %SYSTEMROOT%\TEMP folder after they are committed to the Exchange Store. The Exchange database engine also keeps a small number of these files open for each database. These files are then deleted when:
  • The particular database is correctly shut down.
  • A storage group is dismounted.
  • The Information Store service is stopped.
If the store is not correctly shut down, files may remain that were open at the time of the incorrect shutdown. For example, during a power failure, the store may not be correctly shut down.

↑ Back to the top


Resolution

The Exchange Information Store locks the Lb*.tmp files for exclusive access while the store is mounted. Attempts to delete the files without first stopping the Information Store service do not work, and you receive an error message that the files are in use.

The metadata that represents the file that is being streamed may have to be stored on disk in a Lb*.tmp file while the .STM files are being expanded to hold the data. The size of the metadata can also grow if the .stm file becomes very fragmented.

If the store or database is not correctly shut down, some of the Lb*.tmp files may remain in the folder. If this occurs repeatedly, the temporary files may take up a lot of disk space. If the files or items to be stored in the .stm file are large in size or number, the number of Lb*.tmp files that are created on the disk might also create a disk space problem. Delete these files to free disk space. To delete the files:
  1. At a command prompt, type net stop msexchangeis, and then press ENTER to stop the Exchange Information Store service. You can also dismount the stores from the Exchange System Manager.
  2. Type del %systemroot%\temp\lb*.tmp, and then press ENTER to delete all Lb*.tmp files.
  3. Type net start msexchangeis, and then press ENTER to restart the Exchange Information Store service.

↑ Back to the top


Keywords: KB328583, kbprb, kbenv

↑ Back to the top

Article Info
Article ID : 328583
Revision : 4
Created on : 2/28/2007
Published on : 2/28/2007
Exists online : False
Views : 199