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Caching Problems with Compressed Pages in a Frameset


View products that this article applies to.

Symptoms

You may intermittently receive a "Page not found" error message when you visit a Web site that contains a frameset. This error message may occur if:
  • The frames are generated dynamically.
  • The frames' addresses are the same (except for the query string portion).
  • HTTP compression is turned on.

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Cause

When Internet Explorer caches the pages, it does not use the query string to derive the file name. When the second page's cache file is created, Internet Explorer overwrite the first page's cache file.

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Resolution

Internet Explorer 6

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   16-Aug-2002  10:58  6.0.2720.1600  481,280  Urlmon.dll
				

Internet Explorer 6 Service Pack 1

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   24-Sep-2002  04:08  6.0.2800.1122  483,328  Urlmon.dll
				

Internet Explorer 6 Service Pack 1

Install the Cumulative Security Update for Internet Explorer. To do so, visit the following Microsoft TechNet Web site:

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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More information

Steps to Reproduce the Problem

  1. Create the following two HTML files and put them in a folder on a Web server: Test.asp:
    <%@ LANGUAGE="VBSCRIPT" %>
    <html>
    <head>
    <META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=utf-8" />
    <META HTTP-EQUIV="Pragma" CONTENT="no-cache" />
    <META HTTP-EQUIV="Expires" CONTENT="-1" />
    </head>
    
    <frameset rows="50%,50%" border="1">
    <frame frameborder="1" src="test1.asp?Load=GetHTML1" />
    <frame frameborder="1" src="test1.asp?Load=GetHTML2" />
    </frameset>
    
    </html>
    					
    Test1.asp:
    <%@ LANGUAGE="VBSCRIPT" %>
    <html>
    <head>
    <META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=utf-8" />
    <META HTTP-EQUIV="Pragma" CONTENT="no-cache" />
    <META HTTP-EQUIV="Expires" CONTENT="-1" />
    </head>
    <body>
    <%
    Select Case UCase(Request.QueryString("Load"))
    Case "GETHTML1"
    	Response.Write "PAGE 1"
    Case "GETHTML2"
    	Response.Write "PAGE 2"
    End Select
    %>
    </body>
    </html>
    					
  2. Turn on HTTP compression on the server for both dynamic and static files.
  3. From a different computer, open the Test.asp page. The problem should occur. If it does not, try refreshing the page several times.
Note the META tags. You do not have to use them to to see the problem, but having them makes it easier to see the problem.

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Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

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Keywords: kbqfe, kbautohotfix, kbhotfixserver, kbbug, kbcaching, kbfix, kbie600presp1fix, kbie600presp2fix, kbie600sp2fix, kbie600sp1fix, KB327716

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Article Info
Article ID : 327716
Revision : 18
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 462