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Cannot write or format CBI Mode USB floppy disk drives in WinPE


View products that this article applies to.

Symptoms

During the text-mode portion of Windows versions that are later than Windows XP Setup, or when Windows versions that are later than Windows XP are running in the Windows Preinstallation Environment (Windows PE), you may be unable to format or write to floppy disks in certain universal serial bus (USB) floppy disk drives.

If you keep retrying to write to the floppy disk when this issue happens, the disk may become unreadable. If this occurs, you can reformat the floppy disk to make it readable again. However, any existing data that is located on the disk may be lost.

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Cause

This issue occurs only with USB floppy disk drives that use the Control/Bulk/Interrupt (CBI) protocol, and it does not occur with USB floppy disk drives that use the Bulk-Only or Control/Bulk (CB) protocols. During text-mode Setup and in the WinPE environment, the USB storage driver (Usbstor.sys) incorrectly detects some CBI devices and therefore operates these CBI devices in Control/Bulk mode.

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Resolution

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name    SP level
   ----------------------------------------------------------------
   11-Sep-2002  22:17  5.1.2600.100   22,144  Usbstor.sys  none
   11-Sep-2002  18:15  5.1.2600.1120  22,144  Usbstor.sys  SP1
				
This fix is included in Windows XP Service Pack 2.

Method 1

You must also add the following registry value to the Setupreg.hiv file in the WinPE image after you install the hotfix:
Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\UsbStor\VVVVPPPP

(where VVVV is the Vendor ID [VID], and PPPP is the Product ID [PID])

Value (DWORD): DriverFlags

Value Data:
0x00000001 (1) = DeviceProtocolBulkOnly
0x00000002 (2) = DeviceProtocolCBI
0x00000003 (3) = DeviceProtocolCB
For example, for a CBI-mode USB floppy disk drive with a VID of 0644 and an PID of 0000, the registry value would be the following:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\UsbStor\06440000 DriverFlags = 0x00000002
To add this value to the Setupreg.hiv file in the WinPE image, follow these steps:
  1. In the WINPE folder on the Windows XP OEM Preinstall Kit (OPK) image, locate the Winpesys.inf file, open it for editing, and then add the following line to the [AddReg] section
    HKLM,"ControlSet001\Control\UsbStor\VVVVPPPP","DriverFlags",0x00010003,2
    						
    where VVVV is the VID, and PPPP is the PID for the particular CBI-mode USB floppy disk drive (06440000, for example).

    Save the changes to the Winpesys.inf file.
  2. In the WINPE folder, run the Mkimg command to create a new Setupreg.hiv file, as follows
    Mkimg E: C:\WinPE.tmp
    						
    where "E" is your computer's CD-ROM or DVD-ROM drive, and "C:\WinPE.tmp" is the build location of your WinPE source files.
  3. Copy the hotfix file (Usbstor.sys) to the i386\system32\drivers folder in the build location of your WinPE source files (for example, C:\WinPE.tmp\i386\system32\drivers).
  4. Create the WinPE CD image by using the Oscdimg.exe tool. The following is an example of the command-line syntax for Oscdimg.exe
    Oscdimg -betfsboot.com -n -h c:\winpe.tmp  c:\usb.iso
    						
    where "c:\winpe.tmp" is the build location of your WinPE source files, and "usb.iso" is the name of the output ISO image.
If Method 1 is not appropriate for your situation, you can use any of the following three methods.

Method 2: Use Drvload

When Windows PE starts, use Drvload.exe. Drvload is included in Windows PE 2.0 or later versions to load theUsbstor.inf file. This causes the floppy disk drive to be configured correctly, based on the information that is contained in the Usbstor.inf file, and this prevents the problem from occurring.

Example:
Drvload x:\windows\inf\usbstor.inf
Note Drvload will return the error code "(0x80070103)" if the usbstor driver is already loaded.

Method 3: Use Devcon

Use Devcon.exe with the following command to remove the device. This causes the device to be scanned, and the floppy disk drive can be used.

Example:
Devcon remove "USB\Class_08&SubClass_04"
Devcon rescan

// Class code 08h : Mass Storage Class
// SubClass code 04h : UFI
// Protocol code 00h : CBI


Note Devcon.exe is available as a sample source in the Windows Drivers Kit (DDK).

Method 4: Reconnect the drive

When the issue occurs, reconnect the drive. Be aware that this issue does not occur if you connect the FDD after Windows PE starts.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

USB floppy disk drive models known to experience this issue include the following:
  • Teac Model FD-05PUB-00 (P/N 19308801-00, S/N 0996735)
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbhotfixserver, kbbug, kbfix, kbqfe, KB327242

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Article Info
Article ID : 327242
Revision : 4
Created on : 9/23/2011
Published on : 9/23/2011
Exists online : False
Views : 856