Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: Information Store Stops Responding When You Create a Category View


View products that this article applies to.

This article was previously published under Q326376

↑ Back to the top


Symptoms

When you create a category view, the Exchange 2000 Server information store service may stop responding (crash). The resulting call stack may be similar to the following:
ChildEBP RetAddr 
   92f0f0a4 005cb974 store!EcParseProps+0x36
   92f0f0f4 005cf0cb store!EcDeleteMidFromCateg+0x14c 
   92f0f1c0 005cf450 store!EcModifyMidFromCateg+0x97
   92f0f2fc 005cf669 store!EcCategorizeMessage+0x143
   92f0f354 00428544 store!EcProcessCategMessageEvent+0x109
   92f0f3e8 0048e8d8 store!EcSearchMessageEvent+0x108
   92f0f52c 0048d345 store!OMSG::EcSaveChangesReally+0x18bd
   92f0f694 0048f20d store!OMSG::EcSaveChanges2+0xd4e
   92f0f6d4 0048f180 store!EcSaveOneMessage+0x5a 
   92f0f714 00488957 store!EcSaveChangesMessageOp2+0xa5
   92f0f748 004b3f54 store!EcSaveChangesMessageOp+0x62
   92f0f7ac 00487b26 store!EcSaveChanges+0x13f
   92f0f8d8 00487152 store!EcRpc+0xacb
   92f0f8f0 77d56ee4 store!EcDoRpc+0x60
   92f0f914 77d73bca RPCRT4!Invoke+0x30 
   92f0fd10 77d73589 RPCRT4!NdrStubCall2+0x63d 
   92f0fd2c 77d33e0e RPCRT4!NdrServerCall2+0x17 
   92f0fd64 77d207b4 RPCRT4!DispatchToStubInC+0x32 
   92f0fdbc 77d20688 RPCRT4!RPC_INTERFACE::DispatchToStubWorker+0x100 
   92f0fddc 77d26984 RPCRT4!RPC_INTERFACE::DispatchToStub+0x5e
					

↑ Back to the top


Cause

This problem occurs because an uninitialized memory variable is used when you create a category view. Because the memory variable is not reinitialized, the information store stops responding in some cases.

↑ Back to the top


Resolution

Cumulative Patch Information

To resolve this problem, obtain the March 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
813840� XGEN: March 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

To resolve this problem, install the Exchange 2000 Server Post-Service Pack 3 Messaging Database patch. For additional information about how to obtain this update, click the article number below to view the article in the Microsoft Knowledge Base:
329882� XGEN: Post-Exchange 2000 Server Service Pack 3 Messaging Database Fixes That Are Available

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: KB326376, kbqfe, kbfix, kbexchange2000sp3fix, kbexchange2000presp3fix, kbbug, kbexchange2000presp4fix, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 326376
Revision : 7
Created on : 2/27/2007
Published on : 2/27/2007
Exists online : False
Views : 237