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Some calendar items do not migrate from Lotus Notes to Exchange 2000 or Exchange Server


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This article was previously published under Q326282

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Symptoms

When you use Migration Wizard to migrate calendar information from Lotus Notes to Exchange 2000 or Exchange Server, some or all of the calendar information may not migrate to Exchange.

No errors are logged during the migration.

If you examine the secondary migration file (*.sec file) for the user, you see that the migration file does not contain the missing data, and a calendar message that contains an attachment (*.sc2 file) may not appear in the inbox of the user whose calendar information you migrated.

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Cause

This issue has several possible causes, some of which are related to specific attributes and attribute values in the source Notes database. This article describes two of those possible causes.

Cause 1

Migration Wizard extracts all scheduling and calendar information from the $All view in Notes. Therefore, messages that are excluded from this view are not migrated.

Documents in Notes may contain an attribute called ExcludeFromView. However, Migration Wizard can migrate a document in Notes that contains this attribute unless the content of the attribute contains the value A (representative of the $All view).

To find the value of the ExcludeFromView attribute:
1.Open the item in question.
2.Right-click any white space in the document, and then click Document Properties.
3.Click the Fields tab (represented by a triangle).
4.In the list of attribute names on the left, click ExcludeFromView, and then note the value that appears on the right.
If an item contains the value A in the ExcludeFromView attribute, Migration Wizard cannot perceive the item, and the item is not migrated. If this is the issue, see Workaround 1 in the "Workaround" section of this article.

Cause 2

Every time you migrate recurring meetings, Migration Wizard tries to gather data from the original meeting request, which is also called the parent item. Under certain circumstances, the parent item may no longer be available, or it may exist in another database. This can also occur if the meeting has been rescheduled.

Recurring meetings typically refer to the parent item in the $REF attribute on the child items (the recurring instances of the meeting). If Migration Wizard cannot locate the value that this attribute refers to, the meeting is not migrated.

To find the value of the $REF attribute:
1.Open the item in question.
2.Right-click any white space in the document, and then click Document Properties.
3.Click the Fields tab (represented by a triangle).
4.In the list of attribute names on the left, click $REF (note that items beginning with $ are at the top of the list), and then note the value that appears on the right.
If an item contains a $REF attribute, it may reference a parent item that is no longer available, and therefore Migration Wizard cannot migrate the item. If this is the issue, see Workaround 2 in the "Workaround" section of this article.

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Workaround

CAUTION: The methods listed here may have undesirable effects if you plan to use the Lotus Notes database again after migration.

Certain programs (such as programs that sync data to personal digital assistants (PDAs)) hide items from the $All view to designate items that have already been acted on.

Certain other programs (such as conferencing programs) may rely on the data in the $REF attribute to determine requirements for scheduled meetings, and this data may no longer be available after removing the attribute.

Workaround 1

You can create an agent to remove the A value from the ExcludeFromView attribute. The following procedure removes all values from the ExcludeFromView attribute.
1.Open the mailbox in question in the Lotus Notes client.
2.Open the Calendar view.
3.On the menu, click Create, and then click Agent.
4.In the Name box, type a descriptive name for the agent such as Null out ExcludeFromView.
5.In the When should this agent run? box, leave the default setting (Manually from the Actions Menu).
6.In the Which document(s) should it act on? box, click All documents in view.
7.Click Add Action.
a. In the Action box, leave the default setting (Modify Field).
b. In the Field box, click ExcludeFromView.
c. In the Value box, leave the default value (blank).
d. Leave the default setting Replace value.
e. Click OK.
8.Close the Agent dialog box, and then open the Calendar view.
9.From the menu, run the agent to remove any values in the ExcludeFromView attribute.

Workaround 2

You can create an agent to remove the $REF attribute.
1.Open the mailbox in question in the Lotus Notes client.
2.Open the Calendar view.
3.On the menu, click Create, and then click Agent.
4.In the Name box, type a descriptive name for the agent such as Remove $REF.
5.In the When should this agent run? box, leave the default setting (Manually from the Actions Menu).
6.In the Which document(s) should it act on? box, click All documents in view.
7.Click Add Action.
a. In the Action box, click @Function Formula.
b. Leave the default setting Update existing documents when run.
c. In the Formula box, type FIELD $REF := @DeleteField; @All.
d. Click OK.
8.Close the Agent dialog box, and then open the Calendar view.
9.From the menu, run the agent to remove the $REF attribute on all documents.
After you complete either of the procedures in this section, Migration Wizard can migrate the items in question.

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Keywords: KB326282, kbprb

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Article Info
Article ID : 326282
Revision : 7
Created on : 2/28/2007
Published on : 2/28/2007
Exists online : False
Views : 315