Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

System Attendant Service Does Not Start, Error with a 9022 in Event Viewer


View products that this article applies to.

This article was previously published under Q325964

↑ Back to the top


Symptoms

If you try to manually start the Microsoft Exchange System Attendant service, the service may not start, and some or all of the following events are logged in the Application event log:
Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 9022
Date: 11/14/2000
Time: 4:05:23 PM
User: N/A
Computer: servername
Description: Microsoft Exchange System Attendant encountered an error while processing the security data for Exchange server servername.

-or-

Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 9149
Date: 11/14/2000
Time: 4:05:23 PM
User: N/A
Computer: servername
Description: Microsoft Exchange System Attendant failed to start Exchange server servername. Error code '0x8009000f'.

-or-

Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 1005
Date: 11/14/2000
Time: 4:05:23 PM
User: N/A
Computer: servername
Description: Unexpected error Object already exists. ID no: 8009000f Microsoft Exchange System Attendant occurred.
where drive is the drive on which Windows is installed.

↑ Back to the top


Cause

The system attendant may have a problem when it accesses the key container on the Microsoft Windows 2000 Server-based computer. The first time that system attendant tries to open an existing container, you receive an "NTE_BAD_KEYSET" error message. The system attendant then tries to create a key container with the same name. The key container is rejected, and you receive an "NTE_EXISTS (0x8009000f)" error message, because permissions on one of these key containers are corrupted.

↑ Back to the top


Resolution

To resolve this issue, make sure that the permissions on the MachineKeys folder are not corrupted.

For additional information about how to verify permissions on the MachineKeys folder, click the article number below to view the article in the Microsoft Knowledge Base:
280432� XADM: System Attendant Stops Working with a 9022 Event
After you verify that the permissions on the MachineKeys folder are not corrupted, rename the folder. When you rename the MachineKeys folder, you can manually start the Microsoft Exchange System Attendant service. The Microsoft Exchange System Attendant service then creates a new MachineKeys folder.

To rename the MachineKeys folder, follow these steps:
  1. In Windows Explorer, locate the following folder:
    Drive:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys
    NOTE: Where drive is the drive on which Windows is installed.

  2. Right-click the MachineKeys folder, and then click Rename.
  3. Type MachineKeys.Old, and then press ENTER.
  4. Quit Windows Explorer.
  5. Manually start the Microsoft Exchange System Attendant service.

↑ Back to the top


More information

For additional information about System Attendant that does not start after disaster recovery, click the article number below to view the article in the Microsoft Knowledge Base:
325674� XADM: System Attendant Does Not Start After Disaster Recovery Installation and Event ID 9022, 9149, 1005 Messages Occur

↑ Back to the top


Keywords: KB325964, kbprb, kberrmsg

↑ Back to the top

Article Info
Article ID : 325964
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 379