Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Event 25 Error Message Is Logged When You Create a Print Session by Using Snacfg.exe


View products that this article applies to.

This article was previously published under Q325925

↑ Back to the top


Symptoms

When you print a host print job through a print session that you create by using the Host Integration Server 2000 command line configuration utility (Snacfg.exe), you may receive an Event 25 error message similar to the following in the Application Event Log:
Event ID: 25
Source: SNA Virtual Print Driver
Description: If your print output is correct, this warning can be ignored.

If your session has "Printer Language is Hewlett-Packard (HP) PCL" selected, then the SNA Virtual Print Driver has not recognised your PaperSize (1) or Orientation (1) setting. If your job output has incorrect PaperSize or Orientation, use GDI printing or put the definitions in the START_JOB macro in your PDT file.

If your session is not configured for HP PCL, the SNA Virtual Print Driver cannot automatically apply PaperSize and Orientation Admin settings. If your job output has incorrect PaperSize or Orientation, use GDI printing or put the definitions in the START_JOB macro in your PDT file.

Print Session: <Print Session Name>.
Printer: <Printer Name>.
This problem also occurs when a print session is created by using the Host Integration Server 2000 Windows Management Instrumentation (WMI) provider.

↑ Back to the top


Cause

This problem occurs because the DEVMODE structure for the printer is not initialized correctly when you create a print session by using Snacfg.exe. An Event 25 occurs because the paper source in the DEVMODE structure is not recognized by the Host Integration Server 2000 print service.

↑ Back to the top


Resolution

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Host Integration Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version     Size      File name
   ------------------------------------------------------
   09-Aug-2002   13:44   5.0.0.900   250,128   Snacfg.exe
				

NOTE: Because of file dependencies, the most recent fix that contains the preceding files may also contain additional files.

↑ Back to the top


Workaround

To prevent this problem, create the print sessions by using SNA Manager.

To prevent the Event 25 error for those print sessions that you created by using Snacfg.exe, follow these steps:
1.Open SNA Manager.
2.Expand Microsoft SNA Manager.
3.Expand the configured SNA Subdomain.
4.Expand the Host Integration Server 2000 server where the affected print sessions are defined.
5.Click to select Print Service in the left pane.
6.Double-click an affected print session in the right pane (or right-click the print session, and then click Properties).
7.In the Properties dialog box, click Printer.
8.In the Print Setup dialog box, click OK.
9.In the Properties dialog box, click Apply.
10.Click OK to close Properties.
11.Save the Host Integration Server 2000 configuration.
12.Repeat these steps for each print session that is logging an Event 25 error message.
If the print service is already started when you follow these steps, restart the print service.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Host Integration Server 2000.

↑ Back to the top


More information

Because the print job may print correctly, the only symptom that this problem is occurring may be the Event 25 error message in the Application Event log. In this case, ignore the error message.

If the Event 25 error message is logged for print sessions that you created in SNA Manager, the SNA virtual print driver cannot recognize the paper size or orientation that you specified in the print job or in the print session. In this case, follow the instructions that appear in the Event 25 error message.

REFERENCES

For additional information about the Event 25 error messages, click the article numbers below to view the articles in the Microsoft Knowledge Base:
327359 FIX: Event 25 Error Message Is Logged When the Printer Is Configured to Use the Upper Paper Tray
327356 FIX: Event 25 Error Messages Are Logged for Each Print Job in a Print Session
326561 BUG: Event 25 Error Message Is Logged When You Configure the UNC Printer Name Manually

↑ Back to the top


Keywords: KB325925, kbqfe, kbfix, kberrmsg, kbbug, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 325925
Revision : 6
Created on : 2/22/2007
Published on : 2/22/2007
Exists online : False
Views : 407