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System Attendant does not start after disaster recovery installation, and event ID 9022, 9149, 1005 messages occur


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Symptoms

After you run an Exchange disaster recovery installation, System Attendant may not start, and you may receive the following event ID messages:
Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 9022
Description:
Microsoft Exchange System Attendant encountered an error while processing the security data for Exchange server '<SERVERNAME>'.

For more information, click http://search.support.microsoft.com/search/?adv=1.


Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 9149
Description:
Microsoft Exchange System Attendant failed to start Exchange server '<SERVERNAME>'. Error code '0x80070005'.

For more information, click http://search.support.microsoft.com/search/?adv=1.


Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 1005
Description:
Unexpected error Access denied. Facility: LDAP Provider ID no: 80070005 Microsoft Exchange System Attendant occurred.

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Cause

This issue may occur if the server account does not have the correct permissions on the Exchange server container in Active Directory.

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Resolution

To resolve this issue, use ADSI Edit to grant the correct permissions for the server account on the Exchange server container in Active Directory.

ADSI Edit is located in the Support\Tools folder of the Windows 2000 or Windows Server 2003 CD. To install Windows 2000 or Windows Server 2003 Support Tools, follow these steps:
  1. Insert the Windows 2000 Server or Windows Server 2003 CD in your CD-ROM drive.
  2. Click No if you are prompted to reinstall Windows 2000 Server or Windows Server 2003.
  3. Open the Support/Tools folder. For complete setup information, see the Sreadme.doc file that is available in this folder.

  4. Double-click Setup.exe or suptools.msi.
  5. Follow the instructions that appear on your screen.

How to Use ADSI Edit to Grant the Correct Permissions

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.
  1. Start ADSI Edit.
    1. Click Start, click Run, type adsiedit.msc, and then click OK.
    2. Click Tools, and then click ADSI Edit.
  2. Expand Configuration, expand Configuration (CN=Configuration,DC=domain,DC=com), expand Services, and then expand Microsoft Exchange.
  3. Expand OrganizationName, expand Administrative Groups, expand AdministrativeGroupName, and then expand Servers.
  4. Right-click Server Name, and then click Properties.
  5. Click the Security tab, verify that the server object is in the list of accounts with rights, and then verify that the Allow check box for Full Control is selected. If this permission is not selected, click to select the Allow check box for Full Control, and then click OK.
  6. Quit ADSI Edit.
  7. Wait for the change to replicate among the domain controllers.
  8. Start System Attendant.

REFERENCES

For more information about what to do when the computer account for the Exchange Server computer has been deleted or lost or does not have Full Control permissions to the Exchange Server computer object in Active Directory, click the following article number to view the article in the Microsoft Knowledge Base:
297295 The computer account for Exchange Server is absent

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Keywords: KB325674, kbprb

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Article Info
Article ID : 325674
Revision : 9
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 359