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FIX: COMTI Perfmon Counters Do Not Collect Data by Using Microsoft Operations Manager Client


View products that this article applies to.

This article was previously published under Q325103

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Symptoms

When you try to view COM Transaction Integrator (COMTI) Performance Monitor counters by using the Microsoft Operations Manager (MOM) client, no data is collected and all of the counters show a value of 0.

The same problem can occur with Performance Monitor if your computer is set up to start Performance Monitor before any of the COMTI applications start.

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Cause

If the shared memory that is used to store performance data was created by a monitoring application such as the MOM client or Performance Monitor, COMTI does not use the correct security attributes to gain access to the shared memory.

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Resolution

To resolve this problem, obtain the latest service pack for Host Integration Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
328152 How to Obtain the Latest Host Integration Server 2000 Service Pack
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
   24-Jun-2002  13:24  5.0.0.867    28,944  Comtiperf.dll
				

NOTE: Because of file dependencies, the most recent fix that contains the preceding files may also contain additional files.

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Workaround

The problem described here does not occur if the COMTI applications that you want to monitor start before the monitoring application starts. However, because the MOM client starts during system initialization, the problem always occurs because the COMTI applications are not likely to be running before to the MOM client starts.

If the monitoring application is Performance Monitor (or another similar application), you can avoid the problem by doing one of the following:
Start Performance Monitor after you start the COMTI applications that you want to monitor.

-or-
Configure the COMTI applications to run under a user account that has Administrative rights.

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Status

Microsoft has confirmed that this is a problem in Microsoft Host Integration Server 2000. This problem was first corrected in Host Integration Server 2000 Service Pack 1.

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More information

On a computer that does not experience this problem, when you select the COM Transaction Integrator performance object, a general COMTI instance is listed, and an instance for each COMTI application that is active is listed, also.

When the problem described here occurs, the general COMTI instance is listed but no additional instances are created when COMTI applications are running, so none of the COMTI applications can be monitored. The general COMTI instance counters are not incremented when the problem occurs.

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Keywords: KB325103, kbhostintegserv2000sp1fix, kbhostintegserv2000presp1fix, kbfix, kbbug

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Article Info
Article ID : 325103
Revision : 3
Created on : 2/21/2007
Published on : 2/21/2007
Exists online : False
Views : 345